"last content source....error" driving me, the wife and kids nuts!

you were too quick with the reply!

I have never clicked on the actual entry, so did not know what it did. Here is the result:


Internal error sounds worrying?

Just checked another entry, and realised I had clicked the refresh icon on the first one. This is the entry from the 2nd:


This one says ‘Ready’, but there is still no Media in the library. The ‘Internal Error’ on the first is still concerning though…

Ok.  So while I can’t see your pics yet (they’re moderated) your description is exactly on target.

This happens when the box loses contact with the SERVER, not the network in general.

You can verify this by temporarily setting your PC to NOT go to bed at night – leave it up and running.

I doubt you’ll see a recurrence.

I agree that’s not a fix in and of itself – WD should handle automatic reconnection better.

I’ll disable the shutdown task for a few days, but as it happens I think I already know htis will not solve it…

As part of the messing around I changed the password on the PC with the shares (the old one had symbols etc, and I thought it may be causing a problem). I realised a few days later that the shutdown task was not working because the password it had was the old one, so ther server had been on for four days. I can’t say I specifically checked the WD TV during that time, but I have been using it daily and am sure it will have had problems during that time.

Nevertheless, to be sure I will re-set thWDTV to factory settings tonight, and post tomorrow with the results post 24 hours.

As you say though, if this is the solution it is not something the average man in the street would be happy with.

I’ve taken a look at my box this evening and can confirm that I got the “x” in the media manager folder - on the left hand side at the bottom of the folder icon.  It then disappeared once I re-scanned.

Dont know if this makes a difference, but to confirm, my NAS is still on-line, even when in hibernation…I can see it on line in an IP app on my phone.  So if it’s on-line why does the WDTV think it’s gone?

Also, I’ve just reset the password to the NAS, as suggested by kloneD

The only way I’ve figured out how to fix is to clear saved passwords and re-setup the share.

I’ll see if that helps me and post an update.

Ok… Now that I see the pics, what’s weird is that the LAST SCANNED time is N/A.

Nas remain unaffected and it doesn’t have anything to do with sleep mode or hibernation in the computer as mine doesn’t go to sleep.

It seems to be related to smp rather then the wireless connection.

It seems to loose connection with the smp server after a period of time and its very likely related to the fix they used to address the NAS issue they where trying to fix.

I saw that but was more concerned by the Internal Error…

I’ve just checked, and since I restored it to factory settings & re-established the media library, the timestamp for the last scan is there, and the status is ready.

This is to be expected though, as it does seem to be working fine for around 24 hours. I will check again before & after the 24 hour point tomorrow, and my server will remain on throughout (I have it set not to hibernate/sleep/anything!).


Now it is even more different…

21:40 - WDTV reset to factory defaults, connected to network & shares aded to library. Automatic scanning set to monthly.

23:18 - Media still present in library. Last scan time says 21:40, Starus is ‘Ready’.

09:14 - Media still present in library. Last scan time says 23:18, Starus is ‘Ready’.

11:27 - Media still present in library. Last scan time says 09:14, Starus is ‘Ready’.

14:01 - Media still present in library. Last scan time says 11:27, Starus is ‘Ready’.

17:59 - Media still present in library. Last scan time says 18:00, Starus is ‘Ready’.

21:34 - ‘Media not present’ in library. Last scan time says 18:00, Starus is ‘Ready’!!!

I went to Network Shares and browsed to my server, but the WDTV reported ‘Unable to connect tothe selected source’ (the server had been on continuously). Upon clicking OK on this message and retuning to the home screen, the ‘New items’ counter suddenly changed, so I selected Videos again, and it went straight to my Network Shares, on the server and all shared folders were present.

I selected the Media Library again, but it still reported that there was no media. I tried to add the network shares again, but was informed that the folders were already IN THE LIBRARY!!!

I wouldn’t balme you for questioning this, it really does baffle the senses, and to ensure I am not doing something obviously wrong, I have video’d all of the tests above, the video is uploading here. Skip to 10:25 to see the final test.

I welcome any and all feedback, this is now very amusing/concerning/dissapointing*

*select as appropriate.

Not sure why, but YouTube seems to have cut off the first few minutes of the video where I reset to factory settings and connected to my shares, to clarify the exact steps (as I appreciate this may be in question):

Restore to Factory Defaults.

Settings > System > Set Time & Country > Time Zone > (UTC) Dublin, Edinburgh, Lisbon, London

Settings > System > Set Time & Country > Daylight Saving > On

Settings > System > Set Time & Country > 24-hour time > On

Settings > Appearance > Screen Size Calibration > 95% (looks better on my screen)

Videos > Network Share > Windows Shares > 8-SERVER > Username & Password (Remembered)

Selected three shares & added each to the Library.

The video now cuts in at this point as the Library is being built. The final test is now at 6:00.

Yeah, I agree that’s puzzling. Looking at the timing above, it’s interesting that the last scan time was always the PREVIOUS time you tested, until 18:00 when the pattern breaks…

Surely more concerning is that the last scan time is changing at all, considering that the automatic scan is set to monthly, and no manual rescan was carried out - it seems to scan whenever you go into the media library.

I am really fed up with it now, as this morning I removed the network shares through the setup menu, then re-added them through the videos menu. Put it in standby, then came back to it an hour later to find it had lost them again. I tried to re-add the same way, and now it point blank refuses to accept the username & password. I have factory reset, reset with a pin in the underside, rebooted the server, nothing is working. I have nothing but a paperweight.

So far the only communication I have had from WD is to offer entry to the beta testing program, but that is bugger all use if I don’t have the thing because I’ve thrown it through a window.


I had the exact same problem with my Buffalo NAS. It was set to sleep each night and each morning it would give the last content source error. It happened with the last firmware update. I reverted to the previous firmware version which has resolved the issue. Hopefully this is fixed in the next revision.

After my last post I received a PM from WD saying that they would call me to investigate. although the call never came I have conversed via email with tech support, who have investigated all avenues.

I am posting this message in the hope that other suffering similar issues may be able to use the information to try to resolve their issues.

The end result of my discussions is that my current configuration will not work. The WDTV is having trouble with the Netgear Router in some way. The issue does appear to be related to the DHCP Lease Time according to WD, but only arises with “some Netgear routers”.

If others are having similar issues to me, I would recommend altering the DHCP settings (I cannot advise  what to change, perhaps  TonyPh12345 can?). If you have a Netgear router be aware that the solution could be to replace the router.

I’m having a similar issue.  I just got my WD TV Live for Christmas and updated it to the latest firmware 1.12.14.  Every time the WD box goes into standby it takes a while to compile the library which is a bit of a pain.  If my computer which has network shares is shutdown at night, the WD box thinks the shares are gone.  I have to go back into the setup and rescan the network shares from the media library.  This once again causes the WD box to recompile the library.  I’m considering rolling back to an older firmware but this one is working well aside from the networking issue.  Netflix performance has been solid.  I should also mention that the WD box and my pc have static IP addresses.

If anyone has any suggestions or updates on this please let us know.



I am having EXACTLY the same problem too!! And it won’t be long either till I throw it outta the window!

I’m also using a Synology NAS and have a Netgear router. My NAS is set to hibernate too after a certain time as I certainly do not want to leave it running 24/7 as I only access it a few times a week so it’s a waste of energy and money otherwise.

I have just emailed support before seeing this post but am not expecting much back so has anyone found a solution yet??

I turned off the media library and instead have the content source setup as network share.   The box is faster to turn on and has is more repsonsive while navigating.  I no longer get the error message about the “last content source …”

I’ll probably get flamed or banned for this, but nevermind. I wish the WDTV was a good product, I really wanted it to be.

I have tinkered with one media player/streamer or another for many years - from a very long lead through a wall to the output on a PC (with a wireless keyboard for control) through a dedicated player with no streaming, a Laptop dissassembled and put inside a VCR case, and a few other steps along the way.

When I decided I had tinkered enough and wanted to just buy something that worked, I chose the WDTV after looking at several others. It did not do everything I wanted (how hard would it be to put a DVD drive in one of these?) and did some things I will never use, but it promised to do what I needed it to.

It failed to deliver on that promise.

I don’t really believe WD in saying it is an incompatability of ‘some Netgear routers’ - partially because after I had arranged the return I had the opportunity to try it with a new router briefly, and had even worse issues. Whatever the fault is, it is unacceptable that a company with the resources of WD to put a product out to market that so many people ae having trouble with, and provide so little support.

I expect better from this company, I never thought of them as the kind of company to say ‘you’re holding it wrong’ when the product clearly didn’t work - as other companies do.

I have gone back to tinkering, I have bought a Raspberry Pi and within an hour of receiving it I had a media streamer up and running that provided all the functionality I required and more, and ‘just works’. I am using Raspbmc for information - I am not suggesting everyone ditches WD and moves to this solution, as it is definitely not for everyone. What I will say is that a group of volunteers with nothing but knowledge and determination have created something a company like WD with their resources would have been proud of. Put it in a nice box and customise it and it could be a direct replacement.

On the other hand, there are people  who use that solution who I have pointed in this direction - those that want to plug it in and have it working inmmediately. Those people would be better with a WDTV - if it works for them. If, however, you are prepared to tinker, learn and probably make a few mistakes, it is a lot more rewarding to build something than it is to open a box.

That’s my 2 cents (or equivelant currancy :smiley:), like it or not, based on my experience.

I know the content source would work better as a network share, but that is not what I bought this product for. I like using it setup up in the media library way and after much research prior to buying I decided WD would deliver the best and it seems how wrong was I too. I have to agree with you salawinder in that such a big company with so much resources basically say its the way your holding it'. No, as a customer we are entitled to receive a product that should work to its marketed potential and to have such a trivialbug’ that causes so much frustration to its owners is unfair.

I really hope WD can sort this out and extremely soon or I will be another customer to switch brands.

>>>    If my computer which has network shares is shutdown at night, the WD box thinks the shares are gone.

This is normal operation of shared networks.  It has to do with what is called the “master browser”.  The master browser has been a topic of discussion in a couple of threads this week.  See these thread links for more details: