Laptop can not connect to mybook live without wired connection to Router

Hi.  I’ve spent many days looking for a solution on this but am getting no where, except becoming very frustrated!  So im turning here incase anyone else knows of a solution I could try.

 I can connect to my WD mybook Live whilst I am connected with my laptop (using Windows 7) to the Router (Zyxel P660HW) via a Lan Cable.

The second I unplug the lan cable from my laptop, I am no longer able to access anything on the MBL, neither can I see it in the Network and I’m unable to access it via ip address.

My laptop switches from LAN to Wireless automatically without any problem as I can still access the internet, so I dont believe its a simple connectivity problem from my laptop to the Router. 

As far as I can tell when checking my router settings, I have disabled the firewall so im not sure how that could be causing any issue either.

I’ve tried resetting the router settings, and have re-installed the SW on my laptop for the MBL, but all without any success.

Interestingly I have WD2go and WD Photos installed on my iphone and ipad and they are able to access the MBL wirelessley over the wireless network, or remotely 3G without any problems…

Also another point worth mentioning is that I cant access the Zyxel router settings without being connected with the Lan cable to the Router (i.e. wirelessly entering the admin settings), but I dont know if this is standard or not?

Thanks a million in advance incase anyone has a tip for me…

can you see if, when you go to wireless, perhaps the router is taking the IP away from the MBl and assigning it to the laptop?   Try reserving IPs for all your wireless devices in the router’s dhcp settings.

Hi Cman548

Thanks for comingback,  So I looked in the Router settings again now, Have gone into the DHCP Client settings and checked the reserve box for the 5 wireless devices on my router,   The 4 lan connected items on my router remain not reserved.

It does not seem to make any noticable difference though.

Your WiFi and Wired IP addresses are going to be different if you’re using DHCP – That’s normal.

What I’d guess is happening is that your WiFi “Profile” is configured differently than your Wired profile, and the WiFi profile is more restrictive.

In Windows 7, you can right-click the little Network icon next to the clock, and select “Open Network and Sharing Center.”

Note the Network Profile Name and Type; it’s right under where it says “View your Active Network”:

Do the same check when you switch from one to the other.

Then, you can click the “Change Advanced Sharing Options” on the far left menu.   Note the selections on the one that WORKS.

Then switch back to WiFi, and make note of any differences in those settings – you can try setting them to match the profile that does work.

Hi TonyPh12345

Thanks for your suggestion here,  I have checked the settings as advised it does not seem to make a difference…

With the Lan cable plugged iin and wifi turned off, I see the active network ‘Homegroup’  and when I unplug the lan cable and switch to wifi, It remains as ‘Homegroup’…     I checked the Advance settings in both status’ but again they look the same.


Homegroup?  That’s odd – are you sure you’re in the right place?    Homegroup isn’t a valid network location.

Homegroup is Win7’s proprietary peering scheme.

Hi TonyPh12345

Sorry my mistake,  yes, I was on the right page but mistyped in my reply…  I meant to say  ‘home network’ not ‘home Group’… 

Same point though, weather im connected with the lan cable or wifi, the home network and advanced settings remain unchanged.

I most certainly reserve a dhcp for my MBL, which of course is wired.  That way I don’ t have to rely on whatever DNS to translate the http://mybooklive address into whatever IP the router assigned.  Might as well reserve and IP for everything on your home network and see if it helps.  You can always go back.

So instead of doing the “Advanced Sharing Settings” menu which I said before, click the profile hyperlink (which you are saying is “Home Network” and check the configuration there.  

sorry couldnt check this until now,  Still the same settings in both views…  Its really strange…

I cant tell if its an issue with (1) Windows settings, (2) the Router (3) the My Book Live…     Im tempted to go and buy a new router and see if it solves the issue…   But dont really want to do that unless I know its going to fix the issue…

I have had the exact same problems as you have for the past several months and have been able to only use the wired connection.  I purchased a brand new Netgear AC router last night in hopes of it fixing the problem and it did not fix anything.  I have reinstalled the software, updated firmware for the WD Live and router, etc.  It  seems to be a Western Digital problem.  The drive needs to go back to WD is the only solution that i can come up with.

I exactly have this same problem same senario same router model. WD support is suggesting me that it’s the router setting problem. So far this has been a problem for me for the past month. Can’t still use it on wireless network too.

OK i had this exact same issue.  I have just fixed it.

Here goes:

  1. in my case this was a firewall issue.

  2. So i went into my firewall settings for networks, and noticed that the wired netwoork had a status of ‘Public’ network, whilst the wireless was ‘home’.

  3. So i just changed the wireless type to ‘home’ too.

  4. Saved settings and tried to access WD again and worked perfectly.