Laggy drive


#1

Hello!

I have a WDC WD5000BEVT-22A0RT0 (as seen from the devive manager). It’s this drive I guess, 500GB. I run Windows 7 on a fresh notebook and it goes smoothly without problens.

There is one though.

When I swtich the notebook off (or go to standby) the drive makes a characteristic sound when it stops.

When the HDD is powered again it also makes a characteristic sound.

Why do I say that?

When I play some game (let it be any game or even anything that uses HDD over and over again) it sometimes freezes - lags for a second or two (or three). This happens when (for instance) some new graphics needs to be loaded to game. And it’s pretty old game actually - Call of Duty 1 or Warcraft III (yes, older than 7 years).

Maybe poor hardware? I guess not. 4GB DDR3, ATI Mobility Radeon HD 5650 with 1GB own memory, Intel Core i3 (2.13GHz, 3MB L3 cache). Quite not poor for 7-years old games.

Back to lags. Guess what!

When the lag happens I hear two characteristic sounds. First the one produced by a drive being switched OFF, immediately followed by sound of drive being switched ON.

Whoa! I am here to ask why my HDD spins down only to lag and immediately spin up again?


#2

Most likely those sounds are clicks.  If so, then it’s the drive parking its heads.  Is it possible that you have any power services set that might be shutting down the drive, if it’s inactive for a period of time?


#3

Yes, I guess that when the drive spins down it’s sound is similiar to click.

Power services? I don’t think so - if such exist, they are standard for Windows 7 (or may be part of Acer ePower management or whatever). Anyway I can’t seem to find any option to change this behavior in Windows power management.

But! I have also an external WD HDD - I can hear the very same sounds coming out of it. And this happens when the drive is plugged to Windows 7 notebook as well as old Windows XP PC. I won’t say if it lags my games when making those sounds, as it’s slow comparing to internal drive and generally lags.

It seems that this “head parking” is WD’s job, isn’t it? My Samsung in old PC doesn’t do that either.


#4

Bump!

My problem is still not solved and cool, powerful, brand new notebook still lags on 7-year old games.

Help!


#5

Zylak wrote:

Power services? I don’t think so - if such exist, they are standard for Windows 7 (or may be part of Acer ePower management or whatever). Anyway I can’t seem to find any option to change this behavior in Windows power management.

 

Here’s a picture.  I could be wrong, but as I understand it, the drives should go into sleep mode when the OS calls for it.  So, you could try and see if extending the sleep time helps with keeping the drive active while you playing. 


#6

Ty for answer. Of course I’ve had already tried it.

And as I expected it didn’t work at all. It was easy to predict, as that function was set to 20 minutes by default - the game requests HDD a lot more often, thus that OS setting has no effect on game performance at all.

Just played CoD 1. Lags as **bleep**! Help!

It’s so annoying - every few seconds the game lags and at the same time I hear the spin-up (or whatever) sound! :frowning:


#7

the drive is not good…

recover your data and return it to the warranty

i dont understand why do you continue to test it :stuck_out_tongue:


#8

Lol :expressionless: I’ve already sent my laptop to another country for warranty! The optical drive was faulty. This is nuts! I’ll possibly try calling Acer tech support but I just don’t believe that it’s faulty HDD. I’m nearly sure that it’s some stupid power saving or life extending setting. Whether it’s WD’s or Microsoft’s job and if it’s chanagble (and how) - this is the question.

AND my external WD drive makes the exact same sounds very often - it goes to sleep or parks its heads (or whatever) after very short peroid of time or even while it should work. Though it’s transfer is generally too slow and I can’t say if it lags games the same way, as they lag all time.


#9

can you try the drive on a diferent computer like a normal desktop?


#10

No way, the notebook which it is inside is under warranty peroid. I’d rather not loose it just to know that my HDD is broken!


#11

Bump!

Still need help. I guess that the HDD might try to damage protect its platters. Still I only use it when it sits safely on my desk, thus - how do I switch it off?


#12

You’re kind of stuck on this one.  Laptops are not really good for gaming, but the issues I see are: 1) if you’re playing from ram for a while, then the drive parks the heads, which is what it’s designed to do; 2) when the game calls for more data from the drive, it spins up, and causes the game to lag. 

Some things to consider:

  1. Are you killing all the resources to play?  If you are then maybe you shouldn’t. 

  2. Try multiple window configurations.  Turn off hibernate, sleep, etc.  Turn on Indexing if it’s off, so Windows keeps the drive active.

  3. Are you moving the laptop around? This could cause heads to park, also.

4) Realize that the drive just may not really work for gaming.  Those heads parking are a design feature of the drive, and if you can’t figure a work around that allows you to game effectively, then you will just have lags while gaming.