Lag (Blank Screen) Playing HD, play On, Tversity through Network


#1

I connected through wired LAN with 100MBS. I can stream HD videos flawless from my PC shared hard drive. The issue I am having is WD TV live takes a good 30 seconds to 1 minute  lag before it plays the video. Same thing with Play On, TVersity videos also. Its very annoying to sit with black screen for at least one minute. Does anyone have any solution?

(On Same network connection same videos played instantly using Cinema Tube but I like quality of WD TV live so I want to stick with this box. )


#2

Sounds like a problem with the local network. If you have more than one, try with a different network cable, preferably a decent quality CAT5e or CAT6 cable, and check the ethernet settings of your router. If the port used by the WDTV live is set to auto, switch it to 100 MBit/ half duplex, the WDTV doesn’t support full duplex and autonegotiation doesn’t always get it right.

Also check that your windows firewall, or 3rd party firewall and maybe even the router’s aren’t getting in the way: try to shut them completely for a couple minutes and do a quick test to see if they are not misbehaving.


#3

I tried the Cinematube and its just fine starting up with same network cable. I am using Cat5e cable which I tested and delivering 100mbps to my Laptop.


#4

The WDTV does Full Duplex just fine…  There hasn’t been an ethernet chipset made in the last 5-10 years that doesn’t… :smileyvery-happy:

I’ve also not had a problem with auto negotiation…  

The switch it’s plugged into shows Full Duplex 100 every time I turn it on.

If it didn’t support Full Duplex, it wouldn’t advertise it.  Improper duplex negotiation ALWAYS results in Half-Duplex on the remote end.  That’s the way the standard is defined.  

A bad cable or port misconfiguration isn’t going to account for a 30s start delay while flawlessly sending HD streams.  It’s possibly a subtle issue with how these videos are encoded; it’s taking time for the WD to seek to the video stream in the file.


#5

The HD videos I am streaming are .m2ts file made by SONY SR11 camcorder. Depends on the file size the lag is from 10 sec to 20 secs in this case. Once the video starts its flawless. The quality and sound are amazing.

The other issue is with TVersity. Any program which starts in TVersity starts after 30 Seconds to 1 Minute delay (A blank screen not knowing what’s going on) then the full episode comes with no issues at all. I did Tveristy settings to transcode all videos to Windows Media 7


#6

You make a really good point… “it depends on the file size.”   

It sounds as if the WDTV is scanning that file before it is able to play it.

Look at the Networking tab of the Task Manager to see if it is indeed reading data during that lag.

I don’t have any M2TS stuff, so I can’t see if I can reproduce it.

As to TVersity, if that’s anything like PlayOn, then that delay is normal.   PlayOn, particularly with things like HULU, makes things seem to take forever to start.

TVersity, I believe, is transcoding for the WDTV, so it has to stream enough to begin that transcode process before it starts feeding the WDTV.

Just guesses here…  Don’t bank.


#7

That changes things alright. You don’t need to set TVersity to transcode everything to windows media, it already supports a lot of codecs out of the box (mpeg 1/2/4, H.264/AVC, WMV, VC1 etc…). When you make TVersity transcode videos that would play natively on the WDTV live, it has several downsides: slow start time, decreased quality, and increased system resources, especially high if you wanna transcode to HD. You’re probably gonna need TVersity to transcode those HD videos from the camcoder though, as they’re probably AVCHD and that isn’t supported by the WDTV live I think, but for mostly everything else you don’t.

The way I do it with TVersity is I never mix files of formats that can and cannot be played on the WDTV live without transcoding. That way I can click the “Advanced” button when I add a folder and select either “never” or “always” transcode for each folder. You might also wanna check the transcoding settings, there’s one to select which type of connection you got, and the default wireless setting will probably give you a much higher buffer than it needs to be if you have a wired connection.


#8

Thanks billstpor

Your suggestion worked perfectly. I removed all the Transcoding which fastened the startup time. Most of the videos are playing in WD without transcoding.

I’ve one issue with Tversity may be you can help me on this.  Any HD Video from Tveristy starting fine then within few seconds its going to choppy. After that it’s all choppy. It’s not happening with non HD video.

I checked my the CPU in my TVerity PC which is normal (Never reaches to 100%). Checked Network which is just 10% of 100 mbps. Checked the status in Tversity where it shows streaming fine and its already downloaded the video so no feeding issue also.

How do I troubleshoot this issue? 


#9

This choppiness started after you turned off transcoding? Because you said on your first post that HD videos were playing flawlessly.

Anyways, it seems like there’s something wrong, because I got an Intel Core 2 q6600 (more than 2 years old) and it barely registers in CPU usage when I’m only streaming a video (without transcoding), around 1% or so. If you wrote that yours never reaches 100% that means you probably got a substancial CPU usage, so there must still be some transcoding going on there. You could check what are the file sizes of the videos when you are browsing them from the WDTV, opening them as media server: if they look considerably bigger (or smaller) than they really are (ie a 4.37 GB file looks like 8 GB on the WDTV)  that means TVersity is still going to transcode them.


#10

I’ve home Videos which are HD (.m2ts) files they are flaw less. They are coming from NAS drive.

The choppiness coming from the HD videos of tverisy . The videos are not that big in size probabley less than 5 gb (these are NASA HD videos suggested by Tveristy ). I switched off all the trans coding in Tveristy.  


#11

pandora9 wrote:

I’ve home Videos which are HD (.m2ts) files they are flaw less. They are coming from NAS drive.

The choppiness coming from the HD videos of tverisy . The videos are not that big in size probabley less than 5 gb (these are NASA HD videos suggested by Tveristy ). I switched off all the trans coding in Tveristy.  

Try changing the mode in Tversity to file system.