+++ killed by SIGKILL +++ after new firmware upgrade

Hello,

After I upgraded to the lasted firmware I can no longer wget,curl,telnet etc. All results to a default “SIGKILL”. Any ideas what might be happening and how to fix? I have tried reinstalling the packages and no luck.

strace curl http://www.wd.com
execve("/usr/bin/curl", “curl”, " [http://www.wd.com"], [/* 22 vars */] <unfinished …>
+++ killed by SIGKILL +++
Killed

strace telnet www.wd.com 80

execve("/usr/bin/telnet", [“telnet”, " www.wd.com", “80”], [/* 22 vars */] <unfinished …>
+++ killed by SIGKILL +++
Killed

strace wget www.wd.com 80

execve("/usr/bin/wget", [“wget”, " www.wd.com", “80”], [/* 22 vars */] <unfinished …>
+++ killed by SIGKILL +++
Killed

What do you mean you tried to “REINSTALL” the packages?   Does that mean you replaced the built-in ones?

I just tried Curl and wget on mine with no issues at all.

Telnet, of course, isn’t pre-installed.

It seems like this verision has broken and/or is preventing users from (re-)installing 3rd party apps that had been running fine on previous versions. 

Taking a guess here it could be related to how the libraries are being handled now.

Those preinstalled like wget curl runs fine, though I experienced SSL invalid issues unlike previously.

But I can confirm we can’t install and run new stuffs without the “Killed” result. I first noticed when my installed Java broke including all the build utils :angry:! Let’s find out what’s going on…

I basically ended up downgraded the firmware. This version was pretty much useless. I came to find out OSX shares didn’t work and then other shares were just to slow to stream anything.

After downgrading the firmware it worked as before.

Where to find old firmware?

edit:

rolled back to 3.4. Need to edit etc/version to something like 3.0 to make UI to accept v3.3 file.

Firmware is here:  firmware

I found this online:

“…when you update the device firmware to version 4.x or later. The latest firmware, in fact, uses a modified Debian system with 64K sized memory pages: if you install a package using “apt-get install ” from the standard repositories, almost certainly it won’t run and produce just a laconic “Killed” output.”

There is also a way to build packages in order to work with this 64k sized mem page and therefore continue benefiting from the WD updates.

Check it out in  http://www.mobibrw.com/?p=1554

Cheers,

Jabss