Kein Zugriff auf WebDav über DDNS


#1

Hallo Leute,

ich sitze hier schon fast 2 Stunden an dem Thema und bin echt am verzweifeln.
Ist ja nicht so dass ich diesen Beruf gelernt habe und aus der IT Branche komme. Ich fühle mich echt verarscht langsam.

Ich habe eine WD My Cloud EX2 Ultra.
Habe Shares angelegt und WebDav auf den Shares aktiviert.
Ebenso habe ich den WebDav Dienst allgemein aktiviert.
In der Fritze die entsprechenden Portfreigaben für verschlüsselten und unverschlüsselten Verkehr eingerichtet.

Ich komme auch anscheinend bis zur EX2, aber dann hörts auf.
Bekomme immer die Meldung “403 forbidden”. Das kann doch nicht sein??
Wenn ich im Windows Explorer die Eingabe “\\192.168.178.41\public” mache, funktionierts ja.

Wenn ich das ganze dann über HTTP oder über HTTPS mache, also:
https://meinedomain.ddns.net:6869/public
http://meinedomain.ddns.net/public

… dann kommt das Selbe. Im Browser stehts dann noch ein wenig ausführlicher:
“You don’t have permission to access /public on this server”.

Das liegt doch dann an den Berechtigungen des Verzeichnisses, oder täusche ich mich da?
In der EX2 kann man aber keine Berechtigungen für einzelne Verzeichnisse festlegen, außer die der
Benutzer selber ob die lesen oder schreibenden Zugriff haben dürfen.

Ich werd hier noch wahnsinnig :frowning:

Ich hoffe ihr könnt mir helfen…
VG trekki


#2

Hallo trekki1990,

Ein Remotezugriff ist leider nur über FTP oder WebDAV möglich.


#3

Servus!

Selbes Problem habe ich auch. Bin der Meinung, dass es bei Windows Rechnern am SSL hängt, denn da bekomme ich von außerhalb die gleiche Fehlermeldung.
Vom Android-Handy bekomme ich problemlos trotz SSL Zugriff von außerhalb.

Was jetzt folgt ist gefährliches Halbwissen. Heißt, ich habe das nur durch probieren und “Mundpropaganda” mitbekommen:
Um eine sichere Verbindung über SSL herstellen zu können, benötigt der Client vom Server ein entsprechendes SSL-Zertifikat, welches von einer Zertifizierungsstelle vergeben wird. Nun sind aber da unsere Geräte nicht alle einzeln hinterlegt und die DDNSen sind ja auch meistens nicht nach Schema F (www.xyz-irgendwas.de). Demzufolge vermute ich, dass Windows die Verbindung blockiert.
Warum allerding bei gleicher Konfiguration Android keine Probleme zu haben scheint erschließt sich mir nicht.