Just updated WD Drive Utilities - now all my WD external disks have vanished from desktop

I have just been using one of my 4TB My Book external disks on a MacBook AIR running 10.10.4

All well and good. Only 1 installed at a time using the USB port.

But the system told me there is a WD update so I installed it. Immediately after installing WD Drive Utilities and trying it out the WD disk on the desktop greyed out, then vanished completely. I pulled out the USB cable and put it back into the MacBook. The desktop icon for the WD drive reappeared, but greyed out, then vanished.

So I thought it must be the new update so I uninstalled it using the WD Uninstall program. Same problem. I have an older (2014) WD Drive Utilities install-software on a MyPassport drive so I plugged in the USB for that drive, same problem, that is also greyed out and then vanishes from the desktop.

So I tried the My Book again, using Disk Utilities in the MacBook. It sees the drive at first, but then it vanishes within 5 seconds. Disk Utilities says “Error: A disk with a mount point is required”.

I am very loathe to plug in my other 2 MyBook 3TB drives in case these also vanish or become unuseable for this same reason. I have a huge amount of data backed up on all of these disks. I think the disks are okay and maybe if I can get hold of older WD software from 2014 then I can backtrack and put it back the way it was. As a first step does anyone know where I can get hold of older WD software such as Drive Utilities (I think that was the one which did it). Or is there some files it has installed on the MacBook hidden away somewhere which I can delete?

Okay update. I managed to find an older version of WD Drive Utilities and all disks working again.

But this is something to note for others who might get this problem:-

The brand new v2.0.2.18 causes this problem

downgrading to v2.0.0.23 fixes the problem

At least it did for me.

I found the older version of software on  http://www.macupdate.com/app/mac/52178/wd-drive-utilities/download

Hello, welcome to the community.

Thanks for the information, we have passed this along to WD Support.

July 2015 Solution for Multiple Problems with a New ‘My Passport for Mac’

(Note: I am posting this same message in response to several topics in this Forum, since the symptoms sounded similar to mine and I suspect WD software is causing them.)

Like many other Users here, I recently bought a new external WD drive. The irony here is that I already own 3 other WD external drives, and they have been running fine for several years on our two Mac computers for photo and backup uses. Not so with this new drive. Following the WD installation steps, I first installed their software WD Drive Utilities and WD Security. And then my confusion started, because I now got the message ‘Error in RAID configuration’, even though I don’t use RAID and had done nothing except plug in the new drive. I ran the WD Drive Utility, Status Check, and my laptop actually crashed! I also saw the new drive mount at first, then spontaneously dismount after a minute or so. I even dismounted the new disk, mounted one of my older disks I have used for several years, and now it reported ‘Error in RAID configuration’, something it had never done before, and when I ran the WD Drive Utility, Status Check, on my older Passport drive my laptop again crashed.

Like others here, I wasted a lot of time trying to resolve this, but let me skip all that and get right to what I did to get this new disk (and my old ones) to work correctly again.

Solution which worked for me: I uninstalled the WD Drive Utilities software (the entire folder) completely. So far I have not uninstalled the WD Security software, although I have not dared to use it yet and likely never will. To uninstall WD Drive utilities, I used the free app AppCleaner from freemacsoft.net (NOT the app in the Mac App store similarly named App Cleaner; it may work just as well, but I have never used it.) Now that the WD Drive Utility is off my computer, I can use the new WD Passport and all my older Passport drives. I have run Apple’s Disk Utility, Verify, numerous times on the new drive, and using Carbon Copy Cloner I have cloned up to 340 GB to the new Passport drive, followed by Verifying it, without errors or any of the symptoms listed above.

WD versions for me were:  WD Drive Utilities, which folder contained WDDriveUtilityHelper I hope this helps others on this Forum.

Thanks for the tip. I just installed a 3Tb MyBook for Mac and had the disappearing icon phenomenon. I uninstalled the newest versions of the Utilities and Security software and reverted to the older version of the Utilities software. Now the drive works fine.

I have nothing to add. Just want to thank you folks for those reports. The info might help someone avoid getting into trouble.

People do read these forums!

I have a similar issue with new WD Utility as seen here : "WD Drive Utilities" update for Mac new version is blank" on High Sierra
Also I had to re-install older version of WD Utility from 2016 for it to be usable