Just got My Book Live.. my first thoughts


Plugged in.

Easily found its LAN IP, entered webinterface. Was not positevely surprised how basic it is comparing to ‘mybook world’.

Updated firmware to latest (01.02.03).

Enabled ssh.

Disabled mionet, aftp, twonky, itunes, mDNSresponder.

Noticed that hdd parks head very frequently… like in WD My Book World and there is no way you can change that with ‘hdparm’ (shame WD)…

that is ironic - you do produce NAS but don’t allow to change that head parking value…


Noticed that webinterface runs on ‘apache2’ which seems to causing unacceptably high system cpu load (according to results of  command ‘top’)

MyBookLive:/etc/init.d# uptime
 00:16:03 up 40 min,  1 user,  load average: 1.06, 1.05, 0.95

^ those values is way too high… with MyBook World and mini_httpd this problem was non-existent…

Will definatively do something about it… is it possible to use mini_httpd instead of apache2 ???

Now about LAN transfer speeds… on my Gbit wired LAN via router speed was ~45megabytes/sec to/from NAS.

Too tired to test something else now, but i will these holidays.

p.s. Just stopped apache2, but load average is still about 1 :frowning: wtf.

p.s.s. ok, re-enabled apache2, restarted and values dropped (thankfully).

Now it is:

MyBookLive:~# uptime
 01:27:57 up 4 min,  1 user,  load average: 1.02, 0.70, 0.36

0.36 seems OK ±

p.s.s.s.s. Started “optimization”. When i first logged in to ssh, ps aux looked like this - http://paste2.org/p/1203121 (quite a mess)… so i disabled that and that… and now it is looking like this: http://paste2.org/p/1203125

But still i will try to do more… i believe those sleeping proccesses is not really needed, at least some of them…

Despite all of this, load average tend to go 1.00 or more…


Weird. As you disabled mionet, ftp, etc… you could probably stop the processes loaded at startup too. As your listing “ps aux” shows at least some of them remain. I recommend to install webmin, as this gives you much broader access to the box and makes it - at least for me - easier to configure.

What is the issue with the HDD - parking Heads? Is this an issue of WD Hard Drives or an issue with the MyBook?



Sorry, I missed your second attachment. There are non of the mentioned programs left.

Issue is with WD Hard drives.

you google that easily.

Problem is WD don’t provide any linux tool to change default values or turn off that stupid “feature”.

Why they not changed default value out of factory to more sane number for NAS boxes they producing, I don’t know.

About webmin - probably I will install it soon.