Just got a WD My Book Essentials 2TB USB drive - very slow file copy results in BSOD

Hi, hopefully this hasn’t already been covered in another post. I just got a My Book Essentials 2TB USB drive yesterday and I have not installed the SmartWare software - I want to use the drive as a simple storage drive and I don’t want to deal with any excess software. I tried copying a 2.2 GB file onto the drive through Windows Explorer and the speeds were very slow - progress bar would indicate 9 minutes remaining, then 12, then 17, then back to 9, then 21, etc, but eventually it would result in a blue screen with Machine Check Stop Error. I tried this 4 times with different files, none of which were bigger than 4 gb, and I had the same result each time. Just wondering if anyone has any suggestions. I am assuming (yeah, I know) that this drive can operate as a simple storage device without requiring the SmartWare software to be installed.

My system specs are:

Athlon X2 3800


Windows XP SP2

USB 2.0

thanks in advance,



Format your drive, then just do not install Smartware and you will be able to use the drive as a regular storage unit.