Just cannot get it to work

I have had a look around the forums and have been struggling with a new MPW Pro for a few weeks now. In fact, that isn’t strictly true; I have been struggling with a number (3 to be precise) of MPW Pros. The first one and second ones went back because of SMART errors. I haven’t bothered looking at this one yet because I haven’t been able to properly connect with the device since I updated the BIOS on it…

So I was able to connect to the MPW Pro originally via both the 2.4 and 5Ghz WLAN’s, access the dashboard via a browser and also via the iOS app (iPhone 6s plus), since i updated the BIOS (for which I had to connect to my home network (single word 5 characters SSID and 10 Character alphanumeric password with no special characters); I have either not been able to connect to the MPW’s wifi (IOS \ Windows and MS Phone all tell me the password is incorrect) or I can connect to the wifi but actually cannot access any of the resources on the device (ie dashboard or the app won’t connect). The wifi passwords haven’t been changed from the default that came with the unit - so I know they “should be\are” ok…

When I boot the MPW the default state is that all 6 LED’s continually flash until I hold down the power button for a couple of seconds - then they stop flashing and t get the 2 LED’s on the front light up - but I still can’t connect…

It’s really frustrating as I was hoping the MPW would make a great portable PLEX player for my family, but at the moment - I just can’t get past any initial configuration…

Any thoughts would be appreciated.

Have you tried resetting the unit? Have you tried running the drive in NTFS file system? What capacity of MPWP do you have?

Hi jchen,
Thanks for getting back to me so quickly.
I have tried resetting the unit many times (how long should this take?)

I have a 1TB unit but don’t know what the file system is - I haven’t changed it so it’s whatever it comes out of the box with…

A bit more information - plugging the drive via USB into my laptop seems to halt the 6 flashing LED’s - and at that point, I was able to quickly connect to the 5Ghz WLAN. I was able to connect via the app and then after about 30 seconds, the unit went back into 6 LED flashing mode.

I have found out that the firmware version is 1.03.04

I will try again and see if I can do a destructive factory reset - if I can reconnect later.


Reset shouldn’t take too long. You can do it by pressing both PWR/SD button. Check the UM for exact procedure. The native file system on the drive is ExFAT. You can connect it to a PC to format it as NTFS. But, it seems like you cannot get it to work using direct connection with a PC as well?!. I suggest you contact the WD Suppor team directly.

Hiya, sorry for the delay!

I have done many resets- just wanted to know how long it was likely to take.

In the end, i gave up and have sent it back to Amazon.

Thanks for your help!


This post is kinda old but the issues i had with mpw are not new it seems. Anywhere i go, i see issues with this product and i share the frustration … i also, after 2 days of fruitless frustration sent this thing back to whence it came. I really wanted this thing to work.