Just bought this device, and I am very unhappy so far

When it was updating the firmware, the device would shut off, and not even reboot to finish the installation. Upon manually turning it on, it shut off instantly again, then it turned on properly, showed “Loading” and then powered off again. Eventually it powered on properly and installed the update it finished downloading. Then it shut down again, and didn’t automatically power back up, and I had the same issues trying to get it to power up again.

Okay, good. We finally have the device updated and powered on. I insert my USB stick with my video files (.mkv and .avi), and go to “videos”, then click “local storage”. It greeted me with the message “No storage found”, and wouldn’t detect my USB stick.

I returned to my computer, formated it from FAT32 to NTFS and same deal, it wont detect it.

I bought this machine JUST to play files from my USB stick, and it’s not even working. My blu-ray player detects my USB stick no problem, the only issue is it doesn’t play files other than .mkv.

How do I fix this? I am unhappy about this.


Hi - sorry you are having a poor experience so far. It certainly isn’t a perfect product but I am generally happy with mine, foibles and all.

  1. Have you confirmed that the update applied properly and your current firmware version is the latest?

  2. Have you tried a different USB source with some different media types on to see if it recognises that?

  3. Have you tried both USB slots on the box?

Honestly, the best thing to do is try another USB stick. I can’t tell you how many of them I’ve had that are “faulty”. Faulty meaning they are recognized on some PCs and not others despite the file system. The issue stems from bad USB sticks.

This troubleshooting method should tell you whether it’s your WD TV Live of not.  USB sticks are a dime a dozen.

i Bought this player a year ago.I love this player. I attatched 2 and 3 TB harddrives. never had a problem to play.It might lach with network playback or streaming but best for local playback from drives

I bought 2 SMPs when we had the $50 rebate special (which I haven’t received yet)   :frowning:

Played with one and decided (for my own use, regardless of what others say) to disable the library.  With the library enabled there were “hangs” all the time   :frowning:

With it off I even tried 8 USBs on 2 hubs and it detected 6  :)  It was suggested (here) that the last 2 weren’t detected because it ran out of power.  I have tried USBs from 2Gb to 128Gb.  I even tried a 64Gb SDXC card in a reader.  ALL worked   :slight_smile:

Even with its ‘foibles’ (nice word for it)  :)  it is a marvellous device (especially for AUD$49)  :smiley:

It does NOT, however, recognise my Samsung 640Gb USB3.0 exernal portable but it recognises my USB3.0 128Gb flash drive.  The 128Gb was exFAT which it does NOT recognise.  Reformated it as NTFS and all is sweet   :smiley:

I installed my second SMP at my daughter’s and disabled the library and it, too, is working perfectly.

I have tried about 20 different flash drives on it - ALL worked (except the Samsung ext HDD)…

Sandisk, Corsair, Datastream, Transcend, Topfield, Kogan, Patriot, CENTON and a couple more I have forgotten about…

All in all, a LOVELY device.

BTW it also works well (with a couple of glitches) with my My Book Live 3Tb too   :)   :smiley: