Just bought the SLOW 8TB share space

Hello all!

I have to say that i am not happy so far spending almost 900 euro for this device.

I had a server with 4 Hard disk drives and after 6 years working overtimes mobo died so i  thought not to buy a new 100euro mobo and to invest on a NAS to avoid remote desktops, updates, noisy fans, cables, space etc.

First i tried the auto backup future  that took 32 hours to backup 1Tb of data then i thought must be a firmware issue and updated the device to the latest (2.2.9) but now i can confirm no change in speed.

Then i created some Folders via the web interface and i tried to move some data over the network from /NAS/Public/ to /NAS/photos and then i realized that this gonna take another day because data passes over my wi-fi/G speed old laptop but that’s ok i faced this problem before and i enabled the SSH daemon to move my data faster with bash commands and still speed is terrible. Moving or copying via ssh 150G of data between NAS folders can take 6 hours or more so i decided to create one main folder and drop all the data in and configure the auto back to use this folder.

Then i tried to watch a HD definition movie over the network with my other laptop that is connected with NAS through  a gigabit router and found that movie is lagging every 2-4 seconds!!!  I confirmed that laptop speed and NAS is 1 gigabit  and then tried to copy paste a file from NAS to my laptop and i get no more that 4mb/sec.

This is very frustrating. Never had problems playing HD movies over the network with my old server. I was expecting more from a so expensive device.

My device is set to raid5. Anyone else has speed problems or is something wrong with my device. Any solutions, tips?

I’m looking for someone that has set the device to raid 0. Do you get better speeds?

Thanx in advance and sorry for my English

Your not the only one… I’m using raid 10, with the same problem

Thanks for replying birdii. What speeds do you get from your NAS?

Is this device supposed to work with these speed rates? If yes i’m gonna shoot it with my shotgun and upload it on youtube . This is totally pointless…I hope there is a better firmware soon.

supwner wrote:This is totally pointless…I hope there is a better firmware soon.

I’m disappointed that it isn’t heavy enough to use as a boat anchor. In a nutshell, this thing is useless.

same issue with my ShareSpace 4TB. Tried to transfer at least 116 GB. 8h later. 62 GB. *omg* Time machine is cool, but with this speed?

Please WD help us. We paid a lot of money for your hardware.

I didn’t get the point why the device is so slow. Controler? Firmware? Hardware?

WTF are you complaining about, it took me 1 and a half day to send 800 GB to it, tremendoes…

I have also a Terastation, and if the price of a 8 TB Terastation was the same as WD Sharespace, i had bought that. Typically the speed is bringing very big tears to me eyes, and i hope WD realizes that this culprit needs to be fixed, and i hope some WD staff reads these complaints because they are for real.

Sharespace is still an infant, you guys make  good enough harddisks, but you never, ever should make the step to this market without properly testing.

If this issue is not solved within reasonable time, i’m gonna disrecommend this product line to other buyers. Sellers don’t give a **bleep** what i bought and what our problems are, they just want our money.

Hurry WD!

Now we all know why this device hasn’t got E-sata port LoL…

To those who bought this line of products… RETURN IT ASAP TO THE STORE!!! and then spend your money on better things.

That’s reall all WD needs, a massive returning of this product line, it is horribly slow, and WD is also incapable to solve this problem because i think it is not the firmware but the combined hardware used in the Sharespace.

Sorry WD, but admit that you are way out of your league on this market. Go back to school! And the drawing boards, and return the money to those who bought these very faulty Nas solutions eh culprit

That’s all, i had mine returned just yet and i get my money back, i had to swing with my rights and the Dutch law (the return guarantee rule made by the Dutch/European government) because the machine is far from what it says it is.

Good luck.

BEFORE YOU TAKE IT BACK TO THE STORE…. Read this article from WD… it might just solve your issues…


Looks like WD released a patch about this issue…

1 Like

Ardvark wrote:

BEFORE YOU TAKE IT BACK TO THE STORE…. Read this article from WD… it might just solve your issues…




Looks like WD released a patch about this issue…



Nik71 (I guess he works for Moderator Bill?) posted about this earlier and it did indeed seem to make a difference with the speed issues i’ve been having since my last update. I’m connected to Server 2008 and Windows 7 machines if that makes any difference.

Yes but it has not fixed it, for me at least.

Same problem with me. Been corresponding with WD support. Installed latest patch (Answer ID 5754) mentioned in previous posts. Didn’t help at all.

Eventually got this response from WD support:

We apologize for the inconvenience you are currently experiencing. According to our internal testing and from what we’ve seen from other customers, the WD ShareSpace max transfer speed is 8-11 MB/s on a local network. The drive does not transfer any quicker because that is the maximum throughput that the enclosure’s CPU can handle.


To their credit, they have apologized and have escalated this issue to the developers in charge of the 8TB product.

Let’s hope they can pull a rabbit out of their developer’s hat!

1 Like

The issue here is that it worked ok BEFORE the firmware update, seems they have filled the system up with ■■■■ that slows the hardware down (bit like vista)

The patch did resolve some minor issues, IE not being able to delete a CTorrent file from Windows Explorer, or anywhere for that matter…but it did nothing for the speed issue…which is like watching grass grow…I got better speed from my old dial-up connection…1 hour to transfer a 1.5G file…ridiculous…I got a brand new 4TB last week (my 3rd replacement unit another long story of the incompetence of WD support staff) and it was like lightening out of the box…then like an ■■■■■ I updated the firmware without looking here first…there is no denying where the issue lies.


I’ve just posted this in the firware thread, but thought it was relevant to post again here in case it gets someone’s attention more quickly,  Like alot of guys I’m convinced that the biggest factor contributing to the poor data transfer issues that so many are experiencing is *NOT* down to anyone’s setup; their network configuration or other individual circumstance, but is *ACTUALLY* an issue with the firmware.

The fluctuations in transfer speeds that have been widley reported between the firmware versions confirms this (and the issue of the patch to “correct” the 2.2.9 version would support this assumption too).  Trying to side step this issue is really not playing ball. You must know that you’ve gaffed somewhere along the line, if you don’t recognise this then it serious calls into question your basic competance. Debating this further is a waste of time.  The firmware/unit is at fault.

So, as a paying customer, and a UK resident, I have legal recourse to Trades Descriptions legislation to challenge a manufacturer who is mis-selling their product.  I haven’t read of ANYONE getting the claimed transfer speeds in any tests they’ve made, and WD have been quoted as saying t hat the transfer speeds are more ‘theoretical’ than factual, despite the fact that the markettng blurb suggests that this “theoretical” figure is backed up with a practical test. The fact that WD refuses to allow older firmware, which seemed to perform better, to be reinstated suggests that the solutions lie well within their reasonable means to implement.

So  - could we have a straight forwards answer to the question of what exactly what WD proposes to do to rectify the apparent mis-selling of their product, and to show a willingness to face up to the performace shortfall?

Suggestions I could make would be:

  • Issue an apology for the mis-leading marketing
  • Retract the misleading marketing on future units
  • Make downgrading of firmware  possible (or at lest re-release older versionas) to give users the choice to try different configurations and get the best transfer speed they can without risking a journey of no return
  • The most obvious suggestion might be to start from scratch with the firmware and build it around the idea that additional fuctionality is only interesting once the basics are working properly.

I find it shocking that a commercial organisation with WD reputation would risk so much bad feelings by the kind of users that, by their early-adopter nature, are probably more techically minded than most, and would potentially be opinion influencers for substatial portions of WD’s business.

Given the commerical risks, WD should recognise this as a much bigger issue, and the team in charge of this product/problem should be given more resources to fix this QUICKLY, and PLEASE give us more information about the progress/status!!


GREAT POST! ++++++++++++++++ 1

when you rm your unit, did they send a replacement out first so you could copy your data ?