JPG icon problem for movies - nobody cares?


#1

Hi,

If you use the 1.04.22_V firmware, have you notices that when in VIDEO mode (Thumbnail view), via server (e.g: twonky ) all the movies with icons appear without the icons that belong to them? The movies show the first frame on the movis 

In other words: a film called movie01.avi and has movie01.jpg doesnt show the jpg as its icon but does show the jpg picture with the movie in the same folder so instead of seing vides files, the VIDEO mode shows both bideo and pictures.

Second point of this problem is with network shares. IOn the same VIDEO mode, the jpg files are stiill there but this time the movies do show their rightful icons.

Althow this issue depends on how you arrange your video library, I prefer to keep many movies in the same lib to avoid a lot of remote control action so it’s very disturbing.

I must point that this issue is not a new one, it’s there sing wdtv live! firs appeared and yet, almost nobody speaks of it.


#2

A media server decides what to ‘serve’ to the WDTV and the WDTV has little to do with it. The thumbnails in fact only work correctly when you connect a USB drive to the WDTV. I believe that you can now stop the showing of the jpg in the video folder by adding a period . to the front of the jpg filename. The jpg will then not show up over network shares but the video will show the correct icon.


#3

Hi, 

Was very exited to try your solution but I found that the renaming “video.jpg” to “.video.jpg” is not possible. Windows does not allow it.
Is there anything else I can try?


#4

Jacob wrote:

Hi, 

 

Was very exited to try your solution but I found that the renaming “video.jpg” to “.video.jpg” is not possible. Windows does not allow it.
Is there anything else I can try?

You have to use another program other than windows explorer. I used paint shop pro to load and then re-save when I tried it out. You could use something like explorerXP , that works.

http://www.explorerxp.com/ (free)


#5

Hey RichUK,

T H A N K      Y O U ! ! ! ! ! ! ! ! ! ! 


#6

Jacob wrote:

Hey RichUK,

 

T H A N K      Y O U ! ! ! ! ! ! ! ! ! ! 

I have to say that somebody else on the forum found that this worked and quite honestly I was sceptical, however it does appear to work. I would not rename too many files until you find that it works for you.


#7

Hey, now some people tell me that placing a dot in front of a file makes it invisible in linux OS and since all wdtv run on linux it only makes sence. Only if I knew that before.

Yes, it works for me too. Finaly.


#8

Wow, that’s really good info, richUK.  I think that’s going to help out a lot of people on here!


#9

It has always appeared to work but if you turned off the unit the thumbnails would be lost. However another user recently reported that with the latest firmware it works all the time. You should be able to test this by adding a brand new jpg with a period to a folder and finding out if the unit displays it. If you rename the jpg it could be that the unit is just displaying the old jpg.

As I said this information came from another user and I actually replied saying that I believed it would not work. However I have tried it on a couple of thumbnails and it seems to be the way round the problem.

If people could try it and report then we would know if its a permanent cure.

Here is the original post

http://community.wdc.com/t5/General-Discussions/Movie-artworks-in-separate-jpg-files-work-correctly-with-last/m-p/150810/highlight/true#M19658


#10

After renaming to all files with the " . ", all jpg files were imedatly gone.

When I replaced one icon with another with the same name, the unit stil showed the old thumbnail.

Rebooting did not help so I restored factory settings assuming it will clear the cache and it did, after the next boot the new icon appeared.

As I wrote earlier, putting " . " at the beginning of a file is not possibe with stock XP explorer and a 3rd side software such as the one ‘rickUK’ suggested. In Windows 7 this problem did not appear.


#11

You could probably just leave the unit unplugged for about 10 minutes to get rid of ‘old’ thumbnails if you did not want to reset to factory defaults.


#12

I’ll give it a try.


#13

Jacob,

How did you get on with the thumbnails? Does it still display the thumbnails when powered off overnight?

I got quite downbeat when i read  this but then I remember reading that it works if you use the 1.04.22_V firmware update, quite anxious to give it a whirl myself so I can justify all the time i’ve spent setting this up to the other half by showing her a slick and shiny WD TV Live experience that she’ll enjoy using.

Be a good work - around until the lovely people at WD implement it properly in a firmware upgrade (*wink wink, nudge nudge*) :wink:

Cheers,

Teddy99


#14

Hi,

It took me a while to chack all possible scenarios for the thumb problem so I summerise:

  1. Placing a period " . " in front of a JPG file hides it on wdtv - works both in audio and video.

  2. Adding new JPG requires a reboot to make wdtv rescan the folder for new thumbs.

  3. Replacing a JPG with a new one using the same filename works ONLY after unplugging the unit for couple of seconds.

I placed an idea for improving this situations here:

http://community.wdc.com/t5/Live-Live-Plus-Ideas/Make-wdtv-rebuild-icon-database-with-every-boot/idi-p/155452


#15

I took the plunge and did all the renaming of my library of films, it worked a treat. 

Thanks :smileyvery-happy: