Java error when trying Webaccess

Hello,

First of all, thanks for the firmware update. I tried WD2go apps on Iphone and it is a great added value to my mybooklive drive !

I am now far from home, and trying to access mydrive throug the wd2go.com site, from an XP Pr (SP3) laptop, with firefox 5.0.

After the authentification on wd2go.com, selecting my drive, and providing my user password, the java applet is loading and failing :frowning:

Java Plug-in 1.6.0_26
Utilisation de la version JRE 1.6.0_26-b03 Java HotSpot™ Client VM
Répertoire d’accueil de l’utilisateur = C:\Documents and Settings\Olivier

c:   effacer la fenêtre de la console
f:   finaliser les objets de la file d’attente de finalisation
g:   libérer la mémoire
h:   afficher ce message d’aide
l:   vider la liste des chargeurs de classes
m:   imprimer le relevé d’utilisation de la mémoire
o:   déclencher la consignation
q:   masquer la console
r:   recharger la configuration des politiques
s:   vider les propriétés système et déploiement
t:   vider la liste des threads
v:   vider la pile des threads
x:   effacer le cache de chargeurs de classes
0-5: fixer le niveau de traçage à

charger : classe com.wd.nas4g.mapdrive.MapDrive.class introuvable.
java.lang.ClassNotFoundException: com.wd.nas4g.mapdrive.MapDrive.class
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Exception : java.lang.ClassNotFoundException: com.wd.nas4g.mapdrive.MapDrive.class

Any help on how to fix ?

Is there a possible a workaround ( I tried accessing the drive directly from the windows webdav client with no success)

Thanks !

Sorry you are having issues with this.

It sounds like the Java applet file was not properly downloaded.

 Can you try the following:

  •  disable java applet cache:
    1. Control Panel -> Java -> General -> Settings -> Uncheck ”keep temporary files on my computer”
    2. Restart browser and try again
    3. If you still gets the same error, please check to see if a file with the following pattern exists on your machine “C:\Documents and Settings[Account user name]\Local Settings\Temp\jar_cache[xxxxxxxxxxxxx]
    4. If this file exists, please PM me.

Hello,

I removed all the files I found in “C:\Documents and Settings[Account user name]\Local Setting\Temp & Temporay Internet Files.

At the next attempt, I got a message asking for permission to run a java program. It is now working Ok !

Thanks for your support,

Olivier

I’m assuming from this that the Java install is required, yes?

Likely going to be a problem on my locked down work computer.