iTunes Shared - 'MyBookWorld'

When I try and access the shared ‘MyBookWorld’ in iTunes it doesn’t allow me access. It does this -

  • I click the icon in the sidebar,
  • it gives me a 'Loading ‘MyBookWorld’ message and progress bar for maybe 1 second,
  • I’m then instantly returned to my Music Library,
  • I get no error messages,

I get the same thing happening on both a PC and a Macbook Pro. The MyBook IS however sharing music with my PS3 just fine.

I have tried disabling and re-enabling the iTunes server in the MyBook config, I have also tried completley rebuilding the Twonky database (I don’t know if this actually has anything to do with iTunes sharing though!). I have the latest firmware.

Anything I can try to fix this?

  1. stop he iTunes service
    Go to /DataVolume/jewab/mt-daapd
    songs3.db there and maybe some sort of oither files  DELETE these. by

rm songs3.db

Hi, same problem here with itunes.

krum09, your solution isn’t so clear for a newb like me ^^

How can you access the folder /DataVolume/jewab ?

Thanx for your help

works! ssh is my friend… but quite a complicated solution for regular users…

thx krum