Itunes Problem!

So ive currently have a :

iMac Mac OX Lion  10.7.1

Itunes 10.0.5

Mybook World Editon 10.02.12

I can access my mybook via Finders…

but i cant access via itunes… when i click on my book it just trys and loads

before my updated firmware My Book it still wasnt working…

ive tried Via Wireless + ethernet


I’ve tried Itune via WIndows XP OS it works 

Can someone help me? 

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

There are definately some kinks in the current workings of the Apple file protocol - on my Lion Macbook Pro, I can use TimeMachine and connect to the shares using CMD+K anytime, but trying to use the finder sidebar entry (as reported via bonjour) doesn’t work at all.

I have the same problem - although with Snow Leopard.  iTunes just sits there “Loading MyBookWorld” and nothing happens.  Any suggestions please ?    I am just setting up my NAS for the first time, so far no success using it as a media server at all !   Thanks

Same problem here. 

I have tried to turn off  the iTunes server, to erase the database in  /DataVolume/jewab/mt-daapd and restarting but it doesn’t work.

It reports the following when executing mt-daapd:

iTunes Server for Linux WiDMS v1.50 (0823.008)
Error reading config file (/home/reaper/mt-daapd-arm//etc/mt-daapd.conf)

But I don’t know how to specify where is the config file…

If I killall mt-daapd and reestart with the following command:

mt-daapd -m -c /etc/mt-daapd.conf

Now I can access the server through the port 3659 and it works, scans the song and so on. But in iTunes it stills doesn’t work. I click on MyWorldBook but nothing appears…

Any help???