iTunes library issue with iMac

RE: iMac Yosemite iTunes library loaded from MyBookLive but won’t play songs


I have copied my iTunes library to MyBookLive (updated to firmware 02.43.09-038) and enabled the Media iTunes share setting.

I have no problem accessing MyBookLive through remote mobile apps, from my PC or from my new iMac. On the new iMac I can browse and access all the files and play songs in my iTunes library as individual files in the Finder file maanger.

On my PC iTunes loads the MyBookLive library and can play music without any problems.

On the iMac (running Yosemite) iTunes also loads the MyBookLive iTunes library without problem, but will not play any songs. The song is visible, but nothing happens when I try to press play. Play button is greyed out. Media files all copied from iTunes originally on PC and play OK on iPod/iPad/iPhone OK.

On the iMac opening the get information box about a song shows all the information, but it is all greyed out. Sometimes when attempting to play the file a “wait” icon appears (the colourful swirling wheel like the windows egg timer) but nothing happens. Files copied from the MyBookLive iTunes library to the local iTunes library on the iMac play find. To be clear - volume is up playing local files fine.

I’m a new member here and couldn’t find this same problem anywhere. Any help with this appreciated, thanks in advance for your time.


Have you tried a rebuilt or rescan from the My Book Live Dashboard?

Check page #114 of the user’s manual for more information.

1 Like

Hi, thanks for your reply.

I did try this, apologies for not having stated that earlier. However, I did it after I updated the MyBookLive firmware and am not sure it did it properly - no message said if was completed. Should something say this?

Also to correct something in iTunes on the iMac the play button is not greyed out, but nothing happens when you click it. I have tried in different view, ie. song list, album list etc.

Thanks for your help,

Sorry meant to hot reply rather than new post


I have the same issue.

The library can be loaded in iTunes, but cannot play any song.

In My Cloud forum they reported the same problem, but they say that WD has prepared a patch to solve this issue.

Hope this patch will be available for My Book Live too.

Hi, just want to confirm that rebuilding the library several times didn’t help. From the previous post it seems this is not a unique issue. Any further information or support from WD would be most welcome, thanks in advance for any replies.


If you want WD support, contact them directly and open a case.

This is a user forum, so only end-user to end-user help. Once in a while you might see a WD tech make a post, but it is not the official channel.

It applies to any vendor’s forum btw.


Thanks, I contacted WD and they simply said it was Apple’s issue and not their problem. Not very satisfactory. So any further suggestions from other users who have solved this problem much appreciated - thanks