It says there a videos there... but where are they?


I have just purchased a WD TV Live Hub… and it is not working!!

I have plugged in two different WD external hard drives (passports). In disc manager, I can see my hard drive. On the menu page it lists bla bla new files, but when I go into the videos/music/files tab etc - the only folder listed is the sample one.

I have tried both USB ports - nothing! I am very upset. I purchased a new flat screen to go with the media player, and I cant play any videos!!!

Please hekp =( =( =(

ps: If you are kind enough to help me - please keep the instructions simple. I have searched the site and users seem to assume that others know what they are talking about. This is my first media player.

hi there

  • this is nit hub topic

  • nevertheless pls check whwther once you are navigating to reach Movies that you chosed Movies

[in other  words - once you are navigating within category for example mUsic then you would not be able to see on your tv screen Movie files/titles , you would see then the only music related files/names]

  • pls check the above hint and revert to clear



Sorry, I dont know how to move the topic…

No matter which tab I look at - Video, Music etc - the only folder that shows is the sample one.

I was reading and saw that a USB sync page should come up when a hard drive i splugged in. This does not happen.

On the home page the video tab says there are 178 files… but when you  go into that tab - only the sample one!

I am so mad, I wish I didn’t spend my money on this! It is USELESS - I cant play a single thing on it =( 


try those :

  • just in case and for further specific topic’s help :

  • just check if you are having at all those files on your drives

  • pls check if that drives are allowed [compatibile with your hub]

  • pls check if the drive [via usb] is ntfs formatted

  • pls check if those files are in formats that MPlayer reads them [for example rmvb format would not be read at all]

  • pls try to “map” [in your pc] your disk [usb] that is plugged into MPlayer

and revert - but most of all check those guys in Hub topic - they are fine and good specialists

otherwise come back here with some more details as far as your detailed specifications



The default content source is the internal hard drive.   If you’re trying to use an attached USB drive, you need to change your CONTENT SOURCE to your USB drives.

Go into VIDEOS.

Hit the RED Button.

Select “Local Storage.”

Select “ALL Local Storage”   (This item won’t appear if you do not have MEDIA LIBARARY enabled.)


Select the USB drive you want.



parfait !

shall see if that worked for this guy