Issues with Yosemite - connecting on start up


I have had a My Book live for some time now - and (after some teething issues, when I have forgotten exactly what I did … ) I had it so that it was connecting when my Mac booted, allowing me to use it for a backup with CCC. (Carbon Copy Cloner). I"m not using Time Machine on it, as I have Time Machine running fine on a different hard drive connected directly to my Mac - this was designed so that the Windows laptop can access files etc. etc., etc. 

Now that I’ve upgraded to Yosemite, I’ve had assorted problems, mostly with it not starting up automatically. I’ve tried rebooting, restarting, have even completely reset to factory settings to start over. 

The router is set so that it’s got a static IP address; I’ve used the go to server in finder using both afp & smb. 

I’ve tried to create an alias & it just keeps giving me an unexpected error code (-8060)

I’ve checked the firmware & it’s MyBookLive 02.43.03-022 : Core F/W (and claiming that it’s the latest update) 

I’ve looked at the help files for Using the My Book Live for Time Machine, in case there were gems of information in there - but it didn’t really help. 

If I use smb/afp to connect the server, then it’s happy to run CCC, it’s just it doesn’t work on the scheduled pattern, if the drive wasn’t connected. 

Hello Emmadw, are you having the same problem when you try to copy files manually to the My Cloud? Or just when using CCC.