Issues with WD TV Live Hub - wont stop playing

I have both WD TV Live HD and Live Hub and both do the same thing - if I start a movie (Any format AVI/MKV etc) after about 10-15min I can no longer stop the movie / pause or anything if i want to play another file I have to reboot the device.

I have tried what WD Support has said - reset device / downgrade firmware / upgrade firmware etc etc with no positive result.

Anyone else had this issue - I dont think its my setup as it happens on all my WD TV devices?

Any help appriciated …before I loose all my hair :slight_smile:


if both the Hub and the Live are doing the same thing, don’t you think it’s related to the files themselves? Something in the way they are encoded? Or the hard drive the files are on? Or the connection between the files and the video players? Maybe the router, or the computer serving the files. Just ideas…

Are you playing the files from a NAS? There is a known compatibility issue we’re investigating with certain NAS devices where files played from them cannot be paused.

Yes the files were playing from a NAS (Seagate BlackArmor NAS) - I am busy copying various files to the HUBs hard drive to try that - however I did try playing a few MKV files from a share on a PC as apposed to the NAS and got the same problem. Ill also try plugging in a USB drive to the Hub and see if I have the problem again.

Ill post results later today :slight_smile:

Do you maybe have a link to any list of NAS that are not compatible, if there is such a thing?

It looks like it is behaving with files on the local drive now - but the USB i plugged in still has issues with stopping a movies - is this maybe to do with the fact that the USB drive is NTFS?


No, NTFS is fully compatible.

It seems having the files on the local drive only partly resolves the problem - Some times it is happy for hours but other times it still wont stop after the same 15min of play. And of course playing files off anywhere on the network always has the same result. WD support just tell you to do the normal reset/downgrade firmware/upgrade firmware etc etc and then at the end say the unit is faulty and I need to take it back. They don’t seem to grasp the fact that I have done that already and that it is not just my HUB that is doing this :confused:

Am I alone in this or are there others that have had the same issue?

I’m having a simular problem, not being able to stop it, only i first get an error message then it goes back to the movie only with the spinning circle on screen, also if i hit home it goes to the home page but the soundtrack is still playing in the background . Like you said the only was to resolve this is to turn the player off and start again.

   Really ticking me off, on a side note how do you downgrade the firmware, i thought that might be the next step.


Here is the Email with the links to Downgrade Firmware - this was sent when I contacted them for my WD TV Live HD but im sure there will be links there to the firmware for HUB as well:

Thank you for contacting Western Digital Customer Service and Support. My name is [deleted]

I understand that you cannot stop or pause any media file when you are trying to play it by using your media drive. You may reset your drive by pressing the reset button right beside the USB Port on your drive for one second. I would like to know if you have already updated the firmware for your drive. If you still haven’t updated the firmware I may suggest that you update it but if you have already done that you need to rollback the firmware for it. Attached are the links on how to update and rollback the firmware for your drive.

Answer Title: How to update the firmware on a WD TV Live HD Media Player or WD TV Live Plus HD Media Player
Answer Link:

Answer Title: How to roll back the firmware on a WD TV Live HD Media Player or WD TV Live Plus HD Media Player
Answer Link:

If you have any further questions, please reply to this email and we will be happy to assist you further.

Sorry was not allowed to post the mail but here are the links that are freely available :slight_smile:

How to update the firmware on a WD TV Live HD Media Player or WD TV Live Plus HD Media Player

How to roll back the firmware on a WD TV Live HD Media Player or WD TV Live Plus HD Media Player

Thanks for the help for downgrading firmware but i didn’t help me either, so i’ll called the help deck tonight and see what they have to say.


I too have the exact same problem - 10-15mins into any media file (avi/mkv etc) i am unable to pause or stop playback or fast forward/rewind etc. I have the following setup:

Seagate Blackarmor 220 NAS

Imoega IX2-200 NAS

WRT610 Router

I have this issue with playback on both NAS drives, so it seems to be fairly widespread.

I also contact WD support and was told to update firmware (already using latest version). I’ve done an RMA and returned the old unit and was sent a new one. Same issue again, so seems to be a software issue. Not very impressed considering NAS drive playback is one of the key features!

Anyone at WD know when this issue will be solved?

I have the exact same problem:

Support has been particularly unhelpful: they ran me through the usual stuff (reboot/check internal HDD/check USB/firmware) when it is crystal clear to me that it is a software issue. Basically:

  1. After rebooting, the unit plays every file I’ve tried

  2. If I stop/pause 10-15 min after starting playback, the unit responds normally and I can resume play, choose another file, or whatever

  3. If I let it play for over 20 minutes, then it becomes unresponsive to the pause/stop buttons. However, it does respond to the ‘Back’ button, which takes me to my file listing. The kicker is: I can still hear the audio from the movie being played, which tells me the player has not quit and is working in the background. I can navigate my menus just fine but if I try to play another file, all I get is the spinning arrow. This happens even if I wait for the player to finish (again, going by the audio).

  4. At this point, only rebooting helps.

  5. This happens with files from the internal drive, from USB, from a network share, and streamed with Twonky from a Windows computer.

It is clear that the software player is going into a loop and would not quit. I cannot imagine this to be related to the hardware. Since the unit really plays everything I have thrown at him, I really would like to keep it. But I can’t do it if this means rebooting after every playback.

i have the same problem, after 10 to 20 minutes of playback the time counter freeze and control doen’s work. Don’t know where the problem is but reset etc doesn’t work. Have to reset every time you want to change the file your waching is not acceptable.

Slantchev, if you are using IE9 please visit the link below:

oxter, thanks for the tip… although one should probably worry if the latest & greatest browser can’t post properly :slight_smile:

as for the actual WD problem: I am sorry to report that it went unresolved despite pretty heroic efforts by tech support, which included giving me a direct phone number to call, sending a brand new unit to test, and looking at some of my files for possible encoding issues. Nada. Zilch. Zippo. The new unit did not work just like the one it replaced had not. No problem with the video files I sent. So definitely a software glitch. The problem is that tech support had no idea when, if ever, that particular glitch would be fixed because they could not reproduce the problem in house to debug it. So they told me to return the original unit for a refund, which I did. I am sorry because I really liked the WD TV Live Hub. However, now I am a happy user of Boxee, which works without any hiccups with the same networked setup and files.

Hi you all, I’m Fabio and have had the same issue.

I’ve tried everything you’ve done: tested every type and version of firmware, hard drive, televisions and also different homes (thinking the mine an haunted house).
Western Digital sent to me not one, but two new boxes and … nothing. Always the same problem.

So I have bought the WD TV Live Hub: same problem.

After two month I had the idea: could be some problem whit the router or the NAS?

Yes! The NAS!!

I have a qNap TS-210 and, probably, with the last firmware upgrade, some services have been enabled by default. So I have disabled everything that is not stricltly necessay and now everything WORKS AGAIN!!!

I hope this could help you!

Good nigth from Italy.

Seriously??  That’s bizarre.   I’ve got now TWO Qnap’s and have never seen that.  

Any way you can narrow down exactly which service was at fault?

Well, I have disabled, if they were not have been yet, those under “Network services”, except “Microsoft Networking”, and everything under “Application Servers”.

I don’t know which of them could cause the problem; I going to test it in the coming days.

For sure I can say that the problem is my qNap, because the switching off of it eliminates the problem.

Finally I think that everything has started from one of the last qNap firmaware upgrades because my WD TV Live had been perfectly working for one year.