Issues with WD My Cloud Firmware Update 4.01.01-41​3

has anyone run into issues with share access for different users ? … after installing 4.01.01-41​3 

wd app for ipad and android phone seem to work fine… the issue is while trying to gain access to my network shares using my PC  … 

I tried updating access rights for users but its not working 

what are you seeing from the PC? do you see the shares? Have permission issues?

Have you enables SSH? At all comfortable with Linux?

in windows PC … it shows WDMyCloud in the network and after i log in … none of the shares are shown (and access has been granted in UI for that user) … i tried switching none->readonly->readwrite with no success.

i have and ARM6 running Debian (newbie in linux) and when i tried mount -a my Fstab file (same user) the wd drive denies access just like in windows PC …  (this was working fine before software update)

lastly i used ipad air …  video app that sees shares and i see the same problem …

the funny thing is that android app and ipad app for wd worked fine … maybe they forgot to check this before releasing the software

I suspect the overall_share file got truncated, try ls -l /etc/samba/overall_share

the mycloud and windows shares are controled differently, below is what I found and posted a few days ago. If you try the system only restore please let us now the results. also any steps leading up to the issue.

this happened to me today, a few days ago I upgraded to the latest FW (v04.01.01-413). when I created a share today everything was fine while the share was public. when I set permissions on the new share I lost all SMB shares. the /etc/samba/overall_share file got truncated, I manually re-created it, I suspect a system only restore would re-create it too.

I tried to create and set permissions on another share to re-produce the issue but it is working fine now.

until there is a resolution I would suggest anyone with any Linux experience to make a backup copy of the overall_share file before adding or altering any shares

ok … i try this in the afternoon after work … 

restore system only would not affect the data that is already there correct ?  … the only thing i should do is reassign right to users correct ? 

everything except shares and data is reset

re-created users / passwords

assign access

network configuration

something with remote access

basically look at it like a new device that already has your shares and data loaded, all set to public and I believe media sharing

it worked … thanks for the help !

Maybe i spoke to soon …   after i started to add more users … I noticed that the permissions do not work correctly (tried using different PC’s) … i got to the extreme of doing a full system restore - copy the data over again … created shares, users and experienced the same issue … there is something wrong with this version of software …  

This issue seems to be related only with samba shares … looks like the apps work ok 

then I tried to downgrade my version of software … but the drive tells me there is no enough space to do the firmware upgrade …  

you say the permissions don’t work please provide more details

In file explorer do you see the mycloud? probably twice, once for DLNA and wonce for SMB shares.

Are your shares visable? Can you browse to any of them?

exactly what isn’t working?

FYI, A windows PC can only conect as 1 user to another computer. you can’t connect as user A and user B at the same time

Windows PC or IPAD air (APP with NAS support)

after the full system restore it shows all shares but when i try to map them it either allows access when it should not or denies access when should allow access  …

prior to the full system restore, i did not see  (windows explorer) all the shares (that is why i decided to start from scratch) … it showed some shares but not all …


I created my fstab to map the drive (created a user to manage its access) … but it denies connections to this shares  … prior to the software update it worked correctly 

so DEBIAN, IPAD and WINDOWS show the same behavior. 

earlier you said android and ipad worked with the WD mycloud app. Is this no longer the case?

can you post screen shots of the share including permissions and any errors or anything else you see in windows file explorer.

For IPAD it depends on the APP i’m using 

WD my cloud app - works fine 

XVIDEO (supports NAS - samba shares) is the one with issues 

sure … i’ll be posting the screen shoots soon  … it a nut shell,  i know is the same error that you get when you dont give permissions to people and they attempt to access the share …  (you have not grated permissions … check your network admin)

that makes sense with the IPAD, I thought we were chasing a samba issue

I thought some shares are connecting. Are no shares working?

I spent only 10 minutes … did not do extensive testing but i believe  3 were working and then i started changing to   no access to full access a few times and then they started to have issues as the other ones … is random …  then a created a new user and the same thing you go back and for setting access and at times some of them work  … (access in wd my cloud app always work)  


in the case of debian …  user is debian … notice that debian has read only access but still denies access to 2 of the shares

in the case of windows  user is dorian … it has read/write access and you can see the error below trying to access shared_pictures

from the file explorer screen shot it appears these shares are already mounted, what hapens when you access from there?

can you connect to any of the shares?

right click and disconnect each of the current drive mappings. go into control panel and clear your credential, then try to connect to the dorian share with the dorian user. If this works try the other shares

from the file explorer screen shot it appears these shares are already mounted, what hapens when you access from there?

*I GET SAME ERROR MESSAGE … when i mount them … i login as dorian  … 

can you connect to any of the shares?

*PUBLIC SHARE only  ( notice the share is set as public)

right click and disconnect each of the current drive mappings. go into control panel and clear your credential, then try to connect to the dorian share with the dorian user. If this works try the other shares

*I ORIGINALLY MOUNT THEM AS DORIAN  … at any case at did this as you instructed with the same outcome  

if you connect to a public share 1st you will not be able to connect to any non-public share. Don’t touch any public shares until the other shares are working. Windows does allow you to connect to public shares after you identity is already established. if you connect to a public share 1st that is what your user is established as and it doesn’t matter if you supply a user and password

if you disconect all shares, clear credentials and still can’t connect to the dorian share I am running out of ideas

still sounds like credentials not being cleared

you may need to call WD support

after playing around … go back and for on permissions for each user … i got them to work … 

it was not windows/debian … it was the drive … some how it looks to me that the GUI and the debian software running in the drive are out of sync 

prior of the software upgrade they were working ok 

Thanks for your help !

the /etc/samba/overall_share file probably got corrupted, if everything is working now you can make a backup of it to be sure.

I had it loose shares once and get truncated once. I have not had it loose permission settings before but I am not surprised

what steps did you take to fix this?