Issues with Seagate 2TB hard drive

Firmware - 2.01.86

Updated WDTV Live to latest firmware and the WDTV no longer see’s the Seagate drive, it says no USB device is attached.

I am using a 2TB Seagate drive,  model SRD00F2.

The drive is working as it is recognised by my computer.

It was working on the last firmware, I have tried using another cable, power cycling the unit and reseting factory defauts and using another WDTV Device all to no avail…

A few other people seem to be having thw same issue, please can this be investigated…

Should have said the WDTV is a WDTV Live 3rd gen device

Some more info, its worth pointing out that this is someone else’s media setup…

This is a new drive for them. I have tried reverting to previous firmware versions on the wdtv and the drive still isint recognised. I will raise a support call with Seagate.

I am experiencing the same issue with a portable Seagate Backup Plus 2TB drive.  I have tried partitioning the drive in both MBR and GPT, no dice.  Very disappointing as I was looking forward to having access to a larger capacity drive than my existing 500Gb Transcend unit (fortunately, that one works fine).