Issues with new RE4 drive

Hello,

I recently bought a 1TB RE4 ( WD1003FBYZ), which started to behave badly since the beginning.

The first issue I encoutered was when i tried to initialize the disk: Windows disk manager kept saying “device not ready”.

Then I decided to use WD’s Data LifeGuard Diagnostic tool:  even if the SMART test was ok, the extended test failed reporting too many bad sectors (error 08). Even the write zeros functions failed, reporting error 20 (Delete Partition fail),

as you can see in the image below (on the left).

WD Error update 2.png

After some reboots and several attempts to test the drive, the error in Windows disk manager changed, reporting that the drive was now “write protected”. Googling around I managed to remove the protection and to Initialize the drive. Then I went for a full format, but I had to stop the procedure since it was taking too long (1h for 5% of 1TB, longer than any other drive I’ve ever had). After that i decided to use WD’s write zeros function, which completed in 2.5h without errors.

As the drive seemed to work, in order to double check its health status I launched WD’s extended test: at about 50% progress it stopped, revealing an error. Then I tried again Data Lifeguard’s quick test, without success: it kept failing after 5 seconds with error 07.

Since DataLifeguard’s SMART report didn’t change I moved to HDD sentinel,  which revealed 200+ pending sectors and reallocation events:

I made some more read/wirte and surface tests: while the formers showed quite good speeds, all of the latters failed at around 50 %.

Now the drive’s SMART status is the following:

smart 3

So, there’s my final question: Is the drive broken enough to ask for a replacement ? What other tests should i perform?

Thank you

yeah the first inidicator you already got… DLDIAG failing in smart test

since that failure you could request an RMA…

and now Hard disk sentyinel reports too many bad sectors… yep its dying

Thank you for the confirmation. I’m going to open an RMA ticket immediately.