Issues with my WD Passport 160gb


#1

Hi all,

Hope i am posting this in the right place.

I have had my 160g WD Passport external HD (i think the model number is WD1600XMS-00) for a little over a year now with no issues. Recently i swapped from mainly using a PC to my new Macbook Pro with no issues.

Recently i have been using it more and more for watching movies etc with again, no issues until the other day when i plugged it in and it is simply not registering. It was working fine, i was watching a movie during an especially boring lecture at uni with no issues, ejected the drive as i normally do but when i got home and tried to plug it in, nothing happens on the mac, it just doesnt seem to register it. There is a “whirring” sortve sound when i plug it in, as in the hard drive is spinning or whatever it is that hard drives do, and the blue light comes on the front of the device, indicating its recognised that it is plugged into a USB port, but nothing on the Mac. No hard drive appears on the desktop, nada.

Have tried several times with both USB ports on the Mac to no avail (note that its not a problem with the USB ports on the laptop, have used lots of other USB devices on there with no issues since) and just then tried the HD on a PC and it worked fine, all the files were able to be accessed etc.

Would love any help with this matter, as I’m halfway through a season of How I Met Your Mother… and all the files are on the hard drive… haha

Thanks