Issues with My Net N900 Central

Hi there, I recently got the N900 2TB model, thinking that it would be a great backup method.  I’m using Windows XP SP3.

1.  After setting up the configuration setting, I got the WD Smart Ware backuping up selected folders on my Desktop’s internal hard drive and my external USB hard drive.  I wanted to keep my massive music collection separate from the “smart backup” and so I left my music folder copying to the Central’s storage overnight to the “Shared Music” folder in the public share.  In the morning I noticed that the transfer had been interrupted.  I didn’t write down the error message.  I then tried to open the public share, but couldn’t.  I noticed the hard drive LED on the unit was flashing.  I cycled power, and again the LED hard drive light didn’t stop flashing.  My internet was working okay, but I couldn’t see the drive in the WD Quick View either.  I went to the Dashboard of the wdrouter and noticed that the Attached Storage status did not detect the Central’s hard drive.

After rebooting my computer and the router several times, I managed to get a connection to the Central’s hard drive, but I couldn’t open the “Shared Music” folder in the public share.  I could access everything else on the drive.  I decided to do a Storage Restore command (since it seemed more complete than a normal format).  This took a long time.  Afterwards, I noticed the Software directory on the public share never was populated by the factory restore.

Everything seems to be backing up to the Central’s storage okay now.  The WD Smart Ware is again backing up only selected folders to the “WD SmartWare.swstor” just as I wanted.  This time, I’m copying my massive music collection to a separate “Music” folder and I’m not using the “Shared Music” folder.   I feel unsure about using this as a backup device.  After my first experience I am worried that it is not a robust system and that my data is likely to be corrupted again.  It is the whole reason I paid extra for the Central’s storage - relying on the WD expertise in storage.

2.  Now that my desktop is fully connected, I moved on to my android device.  I installed the 2go software for my tablet.  I want to connect it to the public share - and I see that I need to use the 2go.  So I want to turn it on inside the wdrouter.

I go to Advanced Settings > Remote Access > WD 2go Setup and I notice the Enable Remote Access option is OFF.

I try to change it to ON, the screen changes and it says it’s applying the changes, but when the WD 2go Setup returns, the option is still OFF.

Connection Status says Unknown

COnnection Type says Unknown

Firewall Settings are set to Automatic - It won’t let me change it to XP Compatibility

I click Refresh, and it say Please Wait for half a second, but then returns to the WD 2go Setup screen with no changes present.

Does someone have any advice?

I tried a Factory restore on the connection configuration (it didn’t impact my hard drive) - and set all the setting again.  THe WD 2go still doesn’t work!

Oh, btw with my problem #1 with the corrupted directory -

I wanted to run something like Chkdsk to fix the file system, but you can’t since it is a network drive.  I thought I would be able to, but the storage really is removed from your control.  If I had realized this, I would have bought the cheaper router without storage and paid for a separate USB drive.

Maybe WD could add a file system verification/repair utility to their firmware or perhaps someone could advise on how you can do this remotely on network storage.

Try updating the firmware to the latest version and then do the wd2go setup.

Ofcourse I updated to the latest firmware as soon as I brought it home and applied power.

And I tried to do it again by manually uploading the bin file from my desktop, just for good measure.  No difference.  I can’t turn on WD 2go.  Even after Factory configuration reset, I can’t turn on WD 2go.  It seems that doing a factory restore of the Central’s hard drive somehow permenantly disabled this 2go feature.  I’m tempted to format the hard drive AGAIN and do a factory restore.  It will take a whole evening to get back to where I am.  My time is too valuable for this BS.  Do you think i’d get my money back if I returned it to best buy?  It’s about 1 month old.

I can confirm that when you do “Storage restore” command and format the drive, The drive gets wiped and new firmware is downloaded from WD servers but the software directory which was seen to be populated in the public folder does not get repopulated after the storage restore command. – This is a BUG which I had already reported in this post

See the second post in this list of Storage Router issues