Issues with MLB.tv 2013 Spring Training Games

Just wanted to see if anyone else is having problems with spring training games in the MLB.tv app. I have two 3rd generation WD TV Live boxes and have the same problem on both:

If I happen to access a game in progress, I can watch from the “Live” point, but that is the only part of the app working at this point. For archived games, I cannot watch from the beginning or jump to inning. When I attempt to do either, the “The game will begin shortly” screen shows and I cannot fast forward.

Where you would normally see a time counter showing your position in the game against its total length, all that’s there is “NaNaN:NaNaN.” I’m on the latest firmware and have attempted resets but nothing seems to be working.

Anyone else having these problems? Everything’s working fine on my Roku.

I’m having the same issue. The time shows NaN:NaN:Na and I can’t skip ahead to any inning. It does appear to be playing the “This Game WIll Begin Shortly” placeholder video in the background, and when I tried opening this game on my iOS device, there’s about an hour of this at the beginning. I think what’s happening is the WDTV is playing from the beginning, but is unable to skip the “pre-game” part. 

I really hope this is resolved before April.

Thanks for the confirmation! I was starting to feel like I was alone with this problem.

I have a case open with WD Support and have linked to this thread. I know what you mean about this being resolved by April, but I feel like this should be working for Spring Training. MLB.tv isn’t cheap and one of the main reasons I bought 2 WD TV Live boxes was the MLB.tv support.

Really hoping for a fix to this very shortly. Please comment if you’re experiencing this!

fearandtremble wrote:

Just wanted to see if anyone else is having problems with spring training games in the MLB.tv app. I have two 3rd generation WD TV Live boxes and have the same problem on both:

 

If I happen to access a game in progress, I can watch from the “Live” point, but that is the only part of the app working at this point. For archived games, I cannot watch from the beginning or jump to inning. When I attempt to do either, the “The game will begin shortly” screen shows and I cannot fast forward.

 

Where you would normally see a time counter showing your position in the game against its total length, all that’s there is “NaNaN:NaNaN.” I’m on the latest firmware and have attempted resets but nothing seems to be working.

 

Anyone else having these problems? Everything’s working fine on my Roku.

Any news? I’m using my computer for MLB TV since last summer because it actually works. The MLB TV app has NEVER worked properly on WDTV. Tried it on the WDTV just for kicks and I see the same problem. Honestly they should just remove MLB TV from the WDTV.