Issue with SMB (or could be with Win 10)

#12

No. It’s address is reserved in the router.

Just as an FYI the last Win 10 update I have is cumulative update KB3200970. It was installed Nov 9th.

#13

As a test, try setting the Windows 10 SMB to SMB 1 or SMB3 and see if that works around your issue. See the link I posted earlier in the thread for directions on how to change the Windows 10 SMB version.

#14

OK, I’ll try that. BTW as always, rebooting the MyCloud resolves the issue. It now shows up in Network on my PC.

#15

OK, changing smb-global.conf to smb3. Not sure if I should try 1 or 3 but my windows 10 has ver 3.1.1.

Will let you know how it goes.

#16

Here is the difference after changing MyCloud to SMB3. Not the extra share for MyCloud at the bottom of the second group.

ServerName ShareName UserName Credential Dialect NumOpens


192.168.2.22 xxxxxxxx DESKTOP-EEIOJ9E\xxxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 2.1 1
192.168.2.22 xxxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 2.1 1
192.168.2.22 xxxxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 2.1 1
192.168.2.22 xxxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 2.1 1
DESKTOP-EEIOJ9E Users DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 3.1.1 1
EPSON63F5DF MEMORYCARD DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 1.5 1
EPSON63F5DF USBSTORAGE DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxxxxx@outlook.com 1.5 1

PS C:\WINDOWS\system32> Get-SmbConnection

ServerName ShareName UserName Credential Dialect NumOpens


192.168.2.22 xxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 3.0 1
192.168.2.22 xxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 3.0 2
192.168.2.22 xxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 3.0 2
192.168.2.22 xxxxxx DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 3.0 1
DESKTOP-EEIOJ9E Users DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 3.1.1 2
EPSON63F5DF MEMORYCARD DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 1.5 1
EPSON63F5DF USBSTORAGE DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 1.5 1
WDMYCLOUD IPC$ DESKTOP-EEIOJ9E\xxxxxx MicrosoftAccount\xxxxxx@outlook.com 3.0 0

#17

Have rebooted PC several times since last post and so far so good.

#18

Problem is back. I booted my PC this am and all mapped drives were big red X. Clicking on them resulted in the original error message.

Did the Get-SMBConnection command in powershell and Mycloud didn’t show up. SSH’d into mycloud and ran TOP. Didn’t see nmb or smb. Started SAMBA and my mapped drives work. Also ran Get-SMBConnection and mycloud shows up.

I’m not sure this is the same issue, as before, if I started SAMBA, it didn’t fix things.

#19

One would ask why wasn’t SAMBA running? It’s suppose to start up on every boot.

#20

SAMBA was running when MyCloud last booted. However this morning when I booted my PC it apparently wasn’t. I will be checking logs on MyCloud to see if I can determine why SAMBA tasks weren’t running.

#21

I see this message in the SAMBA log, "WARNING: Ignoring invalid value ‘SMB3’ for parameter ‘max protocol’
".

Will try SMB1 as specified in the thread on Windows 10 methods posted by bennor.

#22

With SMB1 I get these messages:

[2016/12/06 15:51:25.924299, 0] (lp_set_enum_parm)
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’
[2016/12/06 15:51:25.941807, 0] (lp_set_enum_parm)
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’
[2016/12/06 15:52:09.099025, 0] (lp_set_enum_parm)
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’
[2016/12/06 15:52:26.793302, 0] (pidfile_unlink)
Failed to delete pidfile /var/run/smbd.pid. Error was No such file or directory
[2016/12/06 15:55:16.302135, 0] (lp_set_enum_parm)
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’
[2016/12/06 15:55:17.793646, 0] param/loadparm.c:7885(lp_set_enum_parm)
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’
[2016/12/06 15:55:17.824837, 0] winbindd/winbindd_cache.c:3147(initialize_winbindd_cache)
initialize_winbindd_cache: clearing cache and re-creating with version number 2
[2016/12/06 15:57:38.074708, 0] (lp_set_enum_parm)
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’

Apparently smb2 is the only form of the parameter that it will accept.

#23

What My Cloud model and version are you using? What other devices are on the local network?

If I remember right, I don’t think I had problems using SMB1 or SMB3 to access a first generation v4.x My Cloud when I was writing up the Compilation of Windows 10 Methods Steps and Solutions post.

If you haven’t done so already perhaps you should do a 40 second reset as it sounds like you have something weird going on with Samba on your My Cloud. I would also, as another troubleshooting step, disconnect/turn off all other network devices but the router, the My Cloud, and one single computer and then test again to see if the issues persist. I would reboot just those three devices to perform the testing to isolate if the issue is related to some other device on the local network.

#24

Bennor have you checked the samba log to see if you got those messages?

I have a gen 1 Mycloud with the latest firmware.

Even though I got the message it was still showing version 3.0 for the mycloud on the Get-SMBConnection command.See my Dec 1st post.

The only other network device most of the time is my printer, it’s new (a few weeks), and replaced an older printer. Same brand. The problem predates the new printer.

I will consider a 40 second reset. Have to review the implications.

#25

In reviewing some documentation on SAMBA it seems that if the max protocol parameter is left out the max protocol is negotiated between all the SMB clients. Thats probably why it was set to 3.0 when I had those parameters rejected.

#26

If you google the following error message you will see what other people have done to correct this problem.
WARNING: Ignoring invalid value ‘SMB1’ for parameter ‘max protocol’

#27

I’ve done lots of searches and haven’t seen any other instances of WD MyCloud users with this issue, or any resolution. There are many hits on this parameter and invalid values but they are usually other values and in other Linux systems.

My only take away is that there may be need to use the Client max protocol parameter. Perhaps I should specify both Client and server max protocol values.

#28

What is different about your system? Network? Have you made any changes to the original WD files?

#29

Did I check the Samba log for those messages? No and don’t care, Samba was working fine even though I changed the Windows 10 SMB from 2 to 1 or 3 before changing it back to 2. The newer second generation v2.x single bay My Cloud apparently does have an option to change the SMB within the My Cloud Dashboard Settings page. The first generation single bay v4.x My Cloud does not. Instead one could try to modify the /root/etc/samba/smb-global.conf file via SSH on the My Cloud as explained in Windows 10 Specific Method 6 in the Compilation of Windows 10 Methods, Steps and Solutions discussion.

The 40 Second Reset, also known as System Only Restore, will reset the following:
Admin User Name (default = “admin”)
Admin Password (No password by default)
Device Name (default = “WDMyCloud”)
Remove all Users except Admin
All Share permissions (default = Public)
Automatic Firmware Update (default = off)
Network Mode (default = DHCP)
Remove all Alerts
mycloud.com account association (default = not configured)
Mobile app account association (default = not configured)
WD Sync association (default = not configured)
Backup jobs (default = not configured)
Safepoint jobs (default = not configured)

http://support.wdc.com/knowledgebase/answer.aspx?ID=13986

User data should not be affected by performing a 40 second reset.

#30

Nothing different as far as I know. Only change made was the samba conf file change.

Am going to try the 40 sec reset as suggested by Bennor. May take me a few days to get around to it.

#31

I don’t know if you ever found your answer but I recently had to troubleshoot this if you are on a domain you can type in wdmycloud.domain.(com/.net/.local/.etc)\movies or use the ip address of the device in this manner (using localhost as example) 127.0.0.1\movies