Issue with port forwarding 80/443 wd2go (error 31526)

I have already two Web (as well as FTP,…) servers behind my router with port forwarding from Internet to HTTP/HTTPS

one is on 80/443 (back-to-back), another on 8080/8443 and I try to set the MBL on 8000/44300

(I have no difficulty in defining port forwarding on my router [Belgacom b-Box2 = Sagem F@st 3464])

I set 8000/44300 manually on the MBL and I also get the "Connected (Relay connection established)

Port forwarding failed to connect on port 8000 and port 44300 . (Error 31526)" error.

Ports are correctly forwarded as I can check using, for instance, and connect to ( is, at the time of writing, my external IP address) - the result of this connection is “HTTP/1.1 200 OK” - and I can see also the page returned) which prove it works.

So why do I (do we) get the Error 31526 message?

Regards, Pierre

Check if the link below helps.

@Alucardx -
Thanks for your reply. I checked the post in reference but it does not apply -
I am indeed attempting to forward HTTP/HTTPS ports (no FTP involved here) -
btw. in port forwarding for HTTP(S) the type=BOTH is useless, as far as I am aware, HTTP(S) are TCP-only protocols. Anyway, tried it too for safety but doesn’t work better.
Any otheridea?

Yes I am having the same problem using a Billion router this is what I have set up. I also tried HTTPS TCP get same problem

  HTTP TCP 8080 80 Always On  
  HTTPS TCP/UDP 8443 443 Always On  

 This appears in Settings/remote access/configure

connection status

Connected (Relay connection established)

Port forwarding failed to connect on port 8080 and port 8443 . (Error 31526)

Connection Options:

Application Description External Port  Internal Port  Protocol  IP Address (My Book Live)
WD 2go Port 1:* 80 TCP                                                
WD 2go Port 2:* 443 TCP                                                

Anybody got any ideas?

I can confirm that I am also recieving this error!


After awhile of leaving it alone it atuomatically changed to “Connected”.

I did a test, I port forwarded 80 AND 8081 to 80 and 443 AND 8443 to 443, then directed it all towards my MyBook which has a static IP within my network.

I have port forwarded the first ports correctly, and I know this because I have checked manually via http://externalipaddress:80 and https://externalipaddress:443 and they both det a “/UI” at the end with permission denied.

I did the following.

  1. Windows and Router Firewalls are OFF

  2. Checked ports 8443, 443 and 8081, 80 via a third party program/site and confirm that the ports are open,

  3. http://myexternalipaddress:80” redirects me to “myexternalipaddress/UI”

  4. https://myexternalipaddress:443” redirects me to “https://myexternalipaddress/UI

  5. https://myexternalipaddress:8443” redirects me to “https://myexternalipaddress:8443/UI


  1. http://myexternalipaddress:8081”, I receive a "Google Chrome could not connect to “myexternalipaddress:8081”

Is it 6) that everyone could be getting this problem?

The settings in my MyBook live for port forwarding are atm 8081 and 8443 and stating “connected”. I however get the followign error page when I try to connect via


HTTP Status 404 - TCP relay failed - address for target domain not found

type  Status report

message  TCP relay failed - address for target domain not found

description  The requested resource (TCP relay failed - address for target domain not found) is not available.

Apache Tomcat/6.0.32


I get 404 error also via my Mobile App via my Android.

Any pointers?

I also encountered the exact same problems as karlm. However after so much playing around I finally figured out a solution that works for me. I hope this works for everyone else, at least at this point its worth a try .

After following the instructions wd2go I finally decide to change the entire setup.

  1. Do not forward any ports in your router

  2. Enable UPnP on your router ( I think most or all Routers support this) check your router manual if unsure)

  3. Access your dashboard "settings > Remote Access > check Automatic from the connection options dropdown

  4. Disable your Remote Access by unchecking “Remote Access” check box

  5. Restart MyBookLive via settings > Utilities > Reboot/Shut Down > click “Reboot Device”

  6. Once device is rebooted re-enable your device access following step 4.

  7. Assuming steps 1 to 6 have gone through successfully you should now see “Connected”

    Port forwarding connection established.

* to be sure that this will all work lets clear some cache and change some Java options

  1. Clear your browser cache(this should be pretty straight forward)

  2.  Clear your java cache by accessing your control panel  > Java > General Tab > settings> click on Delete files button

  3. Delete any related certificates via control panel  > Java > Security Click Certificates Button > highlight and click remove to remove unwanted certificates.

  4. Ok now you are ready to try accessing your network drive via

1 Like
  • Also this might help if you are having java error issues

  • Make sure you have the latest version of Java installed here

  • make sure you have the following unchecked