Issue with My PassportUSB 3

I just picked up a 500 gig Passport Essential and I’m trying to do my first backup using Smartware. If I use a USB 2 connection, the backup seems to work OK. However if I use my USB 3 (an add-in PCIe x1 card), at some point, I’m asked whether I want to scan and fix errors. It then says I have to reformat the drive. I have tried this once, but I get the same result. Obviously I’d like to use the USB 3 connection if possible. Can anyone give me any insight into what’s happening?
BTW- tried using Acronis from an earlier WD purchase- same result.

You didn’t mention your OS and is it up to date?. Did you check on card makers site for updates? I beleieve there were problems with some of the early PCIe cards.


Hi Joe_S

Thanks for your reply. I am running Windows 7 updated. The USB 3.0 card was bought online and is running with the current drivers. The specs for the card are:

Compliant with PCI Express Base Specification, Revision 1.1

- Supports 2 external USB3.0 port

- Each port provides DC 5V 1A via USB 3.0 connector

- Transfer Rate: 5Gbps 480Mbps, 12Mbps

- Fully compatible with USB2.0 , USB 1.1

- Supports Windows XP//Vista/ Win 7 (32/64) 

- Built-in NEC µPD720200 Chipset

- Support plug and play

  • Driver supported MS Windows 98SE/ME/2000/XP/Server 2003/XP 64-bit/Vista