Issue transferring large amount of data to new EX2

I just setup a new my Cloud EX2 and I’m having issues transfering data to it. For example, I have a large itunes folder I’m backing up to it (just under 200GB). I"ve tried:

  • Attached source drive directly to EX2 via USB, tried to copy over via My Could Desktop App. It works for about 30 min and then 20 min and then I get and error “The following folder was not copied. This can occur of the folder name was changed.”
  • With source drive attached directly via usb, I’vre tried the USB to NAS backup route via the web dashboard. It just says “back up failed”
  • With source usb attached directly to EX2, I tried to manually copy / paste the folder through the finder window. It’s painfully slow. 
  • I currently have the source drive attached to my computer via usb and copying to the EX2 over the network, but again this isn’t the fastest route. 

Any ideas on why the previous attempts failed?

Since this isn’t the first time this question has been posed around here, I will ignore most of it, but you can do a search to see other similar threads.

I would recommend you use your third or fourth bullet methods as they are the simplest ones and to alleviate the slow transfer speed do NOT use wifi but use a wired gigabit connection (i.e. ethernet cable) to connect your Mac to the router. They are not the fastest methods (using SSH would be but that is not for everyone), but they are in my opinion the simplest two methods. You need to keep in mind that if you use wifi you will suffer the penalty of slower wifi bandwidth compared to wired connection.

I do not know why folks use the desktop app at all. I never even installed the app and never needed to in my whole year of using the EX2. Just use your Windows Explorer/Finder for all copy operations within the network.

1 Like

Thank you!

Did plenty of searching and found plenty of comiserating. :slight_smile:

I’ve got it rolling over with the external usb drive connected to the EX2 via USB port on the back. I’m on a newer macbook, so I’ll need to get a thunderbolt to ethernet for that to be an option.

Any ideas on good tutorials or steps for the ssh option? I was able to login to the ssh and poke around, but without the specific commands I didn’t want to risk it. I searched here and google and didn’t really find much specific to the my cloud.