Issue ejecting USB Drive

Hi,

 Have just registered to let you know that I am still having issues ejecting usb drives from Media Player after installing the newest firmware update.

When you go to eject the hard drive from the Media Player it is still not ejecting and hard drive on external drive is still spinning

Any help greatly appreciated

Thanks

I’ve only seen this when something on the network has an active connection to the SMP and/or the drive attached.

It’s possible that something is keeping the file system busy, therefore it can’t be unmounted / ejected.

1 Like

Hello,

Have you tried resetting the media player?

1 Like

Reset won’t work. Tony, my WDTV is also connected to the network when I’m having trouble ejecting. But what could be the cause if there’s only playback from USB? My WD gets assigned the same IP and that should be it.

Don’t know.   It’s just a guess on my part.

But when I was having that issue (sat spinning for 2-3 minutes), I went looking around and realized that I had a window open on my Linux server, with a file browser pointing into the WD’s USB stick.

I closed that window, unmounted the file system, and by the time I got back to my WD, the eject had completed.