Issue connecting to My Book Live folders if not directly connected via Ethernet

I must be missing a setting somewhere.  If I connect my laptop directly to the same router as the My Book Live is connected, I can access the files fine from the Network section.

However, once I disconnect the Ethernet cable and connect to the router wirelessly, I lose the ability to access the drives.

I’ve ensured Remote access is enabled in the settings for the WD Live, even tried adding a user with no password protection, but nothing.

Help!

When you’re connected via Wireless, open a “cmd” window and issue the command

net view

Then connect via WIRED and do the same thing.

Post the output of both times.

In both cases all I get is “There are no entries in the list”.

Just to confirm, I have one laptop that works fine and it shows Mybooklive when I enter the command.  But my other Acer laptop shows “no entries”.

The below is what I see on the laptop that can connect and allow me to copy/save etc. to the MyBook Live drive:

But this is what I see on the other laptop (you can see it doesn’t show the MyBookLive in the folders section, just on the left hand side):

Interesting.  So if I right click on the MyBook Live icon (not sure why one is the actual Mybook Live black icon and the other is a different colour on both computers given they are both running Windows 7?), I can click “Open” and it opens up the drive and I can see the files.

But if I close Explorer and reopen it, I have to again click on the icon and right click “Open”.

The issue is, I can’t do this when trying to use programs to find the folders.  E.g., Foobar (a music program) needs to see the MyBook Live folders in the Network area).

This is exceptionally frustrating.

BTW, called WD Support and they had no idea either.  Asked me to call up Microsoft Support or Acer support.

It sounds like that PC has Windows Networking completely disabled.

I had a similar problem awhile back with WinXP SP3 on a Dell Inspiron 9300 via a wireless connection. NET VIEW was showing up blank. Started investigating and finally found the culprit. Checked Event Viewer - System and saw an Error. The error text was:

“The name “WORKGROUP :1d” could not be registered on the Interface with IP address 192.168.0.15. The machine with the IP address 192.168.0.12 did not allow the name to be claimed by this machine.”

It turns out that IP 192.168.0.12 had been assigned to my RIM BlackBerry PlayBook (The Dell was 192.168.0.15). The PlayBook was at Standby at the time but like the MBL, when the PlayBook is at Standby it is still very much alive - especially its Wi-Fi interface (its still checking for email, OS and software updates, etc). Disabling the Wi-Fi on the PlayBook corrected the problem and with the PlayBook out of the equation, NET VIEW gave:

DELL-INSPIRON         DELL_Inspiron_9300
MYBOOKLIVE               My Book Live Network Storage

(both lines above preceeded by “BackSlash ‘’, BackSlash’’”; but I was not able to include them as the WD posting checker reported ‘invalid HTML’)

The command completed successfully.

I’m not suggesting the above problems are due to a PlayBook - they are pretty few and far between. However maybe something else on the network is causing a similar problem.

William - thanks, but I don’t see any errors in Event viewer.

Tony - any ideas how I can check and/or correct that issue if networking is completely disabled?  I’ve looked up all the entries in the Services area, but they appear to permit networking and are identical to the other laptop that works fine.