Issue after formatting Black2


I’ve installed Windows on my black2.

After, i wanted to format it and clone my old HDD. But now, I have only one partition of ~1040Gb.

How reinitialize my Black2 ?


Hi. I had the same issue.

I tried to reinstall system in black2 (moving from windows7 to 8.1) and the installation steps shows a single drive with 1040GB.

The user guide says that only 120GB (SSD portion) can be showed for systems installation. But, when you run the software for the first time, it likes that something happen with HDD firmware.

So, can I bring back the HDD to original state (because the usermanual shows that the you cannot run SSD and HDD together in a single partition, and may cause data loss).



If the drive is showing up as a single partition then you have spanned the partition across the SSD and HDD partitions, which is not supported because even though the drive is in a single form factor the Black2 is actually 2 separate drives.

Have you tried uninstalling the Black2 installation software?  You should be able to run the software again and it should have an option to “Remove” it.

1 Like

Hi Tinwarble, thanks for answer. Well, it´s possible.

But, I don´t understand why only 120GB are showed in first time, and after software installation, without any operating system, the computer shows 1040GB.

How can I find again the 120GB for the SSD and the 930 for HDD? I can´t believe that WD cannot made a repair to this issue! In other cases, if you do an error when partioning, you lose data, but in this case, you lose your disk!!! No… I don´t think so.

Fact… There´s no information in manual or PDFs from WD about an format or repartitioning situation. Maybe one day, if you plan to change this disk to another computer, caution!

I´m trying to understand an XML file in Black2 sofware. I hope that it uses diskpart and create the hdd partition using logical sectors to determine where SSD ends and HDD starts… Hope…

I would like that WD releases an official information about this issue and a kind of firmware or repair software to back this HD to original state!

Thanks again!

Ok, I see what might be your problem.

You say you didn’t install any OS “and after software installation, without any operating system, the computer shows 1040GB”, if you didn’t that is why your showing 1040GB.

The Black2 is not meant to be a secondary drive, it’s meant to have the OS installed on the SDD portion of the drive.

I know that it does state that specifically (anywhere that I could find), with the exception of this:

  • Why is software required?

    • Software is required to unlock the 1 TB portion of the dual drive. The SSD portion is available to install/clone the OS to it.

And in the Quick Installation Guide:

WD Black2 Dual Drive is a fusion of a fully accessible solid-state drive for your operating system with a generous capacity hard drive for personal data and large files.


Also, there is information about returning the drive to factory configuration here:

  • How do I return the dual drive to factory configuration?

    • WARNING: Returning the drive to factory default configuration requires deleting the 1 TB HDD partition. This will permanently erase all data off the HDD.
    • Please backup and remove all data on the HDD partition. Delete the HDD partition under Windows Disk Manager and then run the WD Black2installation software and choose the “uninstall” option.

I bought this drive from Amazon. It was “used”

I tried to Ghost my Windows 7 partition, but never did see a 120GB partion. I have tried “Uninstalling”

the WD2 software, but it doesn’t give me the option.

Disc management shows the drive, but not as 120GB.

I need to find the solution to restore this drive to out of box, so that I can clone my OS, activate the 1TB partition,

and move on from this frustrating mess.

dslmike. Trying using DLG Diag to preform a Write Zeros (quick should be fine). This should reset the Black2 back to factory defaults and just display the 120 GB SSD again. If not, you may need to install the Black2 software so that it properly splits the drive into two volumes. I included two version of the software below so choose which one would work for your situation.

Another thing I would check is make sure that your BIOS is set to AHCI and not RAID mode if you can adjust it. This could prevent any problems you may encounter while installing the Black2 software later.

DLG Diagnostics (Windows)

DLG Diagnostics (DOS)

1 Like


I have exactly the same problem as described by lveusse.

I bought the drive on April 16th (9 days ago), then installed Windows 8. Was able to make the 1TB HDD visible and everything worked fine for a while.

Then, about three days ago, the Windows 8 OS got corrupted. Initially it wouldn’t wake up from the standby mode. After some trying, finally it started again after I placed the Windows recovery CD in the DVD drive bay. But then the OS was corrupted (for instance, the task manager was frozen).

So I tried to repair the OS with the Windows 8 recovery DVD (my PC is a Sony Vaio S15).

What happened is that, instead of just repairing the OS, the entire OS was installed again and apparently the drive was formatted.

This resulted in a drive with a size of 1043GB. SSD and HDD no longer visible.

I tried to install again the WD software but got the following error message:

"An error has iccured while installing WD Black² Dual Drive

Issue description:

Not enough free space on the HDD part of the drive.

Completion code: 13"

I tried formatting again the drive and installing again Windows 8, but still got a 1043GB drive and could not install the WD software.

I just tried using DLG Diag to preform a Write Zeros (quick) but it would not work.

Then I tried to do a complete write zero. Got an error message after about 16 minutes (must have been when the zero write operation was completed on the SSD part). Let it continue running until the sector count reached 290 million, then stopped it. It was still showing over two hours of completion time.
Unfortunately the drive still shows as a 1043GB single drive. What else can I do?

1 Like

Make sure that you are doing a write zeros with the DOS version, that way the drive is not in use by the OS. You will need to boot from a USB stick or something. If you still have Windows installed what does it show in Disk Management for capacity and used space? If over 120 GB of space is used then the software can’t install since the data totals more than what the SSD can hold. This will cause the error that you saw with the Black2 installer.

It may be easier if you call our Tech Support because they can help you with the issue and try to get it resolved.

Contact Tech Support

Complicated. How can I create a bootable DOS USB stick, i.e. where can I get the software from?

I have started the full write 0 operation again and get this error message:

“Sector #234441472-234441728: Write Zeros error! Continue?”

Seems that the write 0 operation reached the end of the SSD.

Win 8 is no longer on the drive, since I made a write 0 operation. But the used space was less than 120GB (just installed windows).

I suspect that the WD software thinks the drive consists of a 1043GB SSD with no HDD, and therefore refuses to install.

I also opened a ticket with tech support yesterday, but got no answer yet.

Doesn’t WD have a simple tool to fix this kind of problem?

The instructions on the download page for DLG Diagnostics for DOS has a link on how to create a bootable USB stick (step 2). There is a utility called Rufus that makes a USB stick bootable, then you just copy the DOS version of DLG to the stick, boot off it, and then run the DLG command to start the program.

Windows will still install on the drive, even if a partition cross the “gap” between the SSD and HDD. The Black2 software is what splits the partition into the SSD and HDD. Since there is no OS on the drive I would make sure that your BIOS is set to AHCI and not a RAID mode. Sometimes this can cause problems with the software.

The tool to fix it should DLG Diagnostic and the Black2 software. This resets the drive and should hide the HDD and just show the 120 GB SSD. However, in some systems it may show as 1043.30 GB. This just means a single partition was created and the 1 TB drive is already unlocked. If you still have problems with the DLG then I would try installing Windows again, make sure you have the latest drivers, and then run the Black2 software to have it “fix” the partitions. Another thing that you can check in the BIOS is SecureBoot. Try turning that off to see if it helps since you are using Windows 8. SecureBoot prevents a program from modifying a partition/files during bootup, which the Black2 software may do to adjust the partitions.

Well, this write zero step seems to take hours. It’s now running already for almost two hours and has reached only sector 1.39 billion out of 2.18 billion. Will probably take another hour and a half to complete.

I’m therefore not exactly eager to start the operation again from DOS, also considering that there is nothing on the drive not even a partition, so how would Windows 8 interfere with the write zeros operation? FYI, the WD Black2 is currently connected with the USB to SATA cable to my computer.

Installing the operating system also takes hours, with the drive in this current status (I have a Sony Vaio install DVD which together with Windows 8 also installs drivers and additional software). In this 1043GB status the WD Black2 drive seems to be quite slow.

I already tried to delete the partitions (albeit not performing this write to zero operation) and install Windows 8. But then, when I tried to install the WD software, I got this completion code 13 error. I also tried to install the WD software on another PC, but it refused to install because it said it could not find the WD Black2 drive, even if this drive was connected as an external drive via USB.

To make myself more clear: THE WD BLACK2 SOFTWARE REFUSES TO INSTALL. Therefore I cannot use it to fix the problem.

Can WD provide another simple low-level tool which does some low-level format or similar operation which fixes the drive?

If you are doing a write zeros using a USB-to-SATA connection that is fine. You don’t have to use the DOS version. Also, the Black2 software will not detect the drive on USB. The Black2 drive has to be physically inside the system.

The only utility that WD has is the DLG software.

Update and solution to the issue:

  1. First of all it appears that when you “install” the HDD with the WD Black2 software, a new partition is added to the disk and the total size is increased by 1TB. The computer then sees the WD Black2 as one drive with one or more SSD partitions and one 1TB HDD partition.

  2. The Sony Vaio S15 recovery disk sees one HDD with some partitions on it. It doesn’t care about the partitions, deletes them first, then installs Win8 with a 5-partition structure (three support partitions of 260MB, 1.44GB and 260MB; one main C: partition with the OS and one hidden 36GB recovery partition). The Sony Vaio S15 recovery disk does not ask on which partition you want to install Win8.

  3. Therefore, if Win8 gets corrupted, because the WD Black2 HDD is not fully compatible with the standby mode of Win8, and you try to refresh the OS, the mess happens.

I solved the problem by deleting all partitions on the WD Black2, creating one 97GB partition (which therefore would be inside the SSD), mounting the WD Black2 into an old Lenovo X200 notebook and installing Vista 64. Then I was finally able to install the WD Black2 software and finally uninstall the HDD, thereby returning the WD Black2 to the factory status.

By the way, the WD Black2 software, even if installed, does not show up in the start menu. To be able to use it to uninstall the HDD, you have to run again the installer. Quite confusing, because when you run an installer you would assume that the software gets installed, but apparently this is not the case with the WD Black2 software.

Suggestion for WD:

a. Nowhere in the user manual (“Quick install guide”) it is mentioned that you need to uninstall the HDD with the WB Black2 software first if you want to refresh the OS. You should make this very clear, otherwise these kind of problems will happen again.


c. Create and make available a simple tool which allows to reset the WD Black2 to factory status, even if the drive is only connected to the PC as an external USB drive.

1 Like