ISO/VOB stutter

I just bought a WD TV Live and updated it to the latest firmware and ISOs stutter badly, for both DVD and BD images.

My storage device is a 20TB nas with gigabit ethernet, over samba and my old player was an original Xtreamer, which played these files from this storage without issue.

My ISOs have been ripped with AnyDVD HD.

If I re-encode to .mp4 (H.264+AAC) via ffmpeg and x264, the .mp4 plays without issue, even if it is the same size as the original VOB.

If I extract a 50GB .m2ts from a BD ISO, it still plays fine.

The issue happens on both playing the ISO directly, and extracting to a AUDIO_TS / VIDEO_TS directory structure and trying to play VOBs. In fact, if I extract it to this directory structure, the WD TV Live even struggles to respond when navigating the directory (e.g. it’s hard to open VIDEO_TS or scroll down to VTS_01_1.VOB - it can take up to about 30 seconds to respond to a button press on the remote).

Does anyone else have this issue on playing ISO / VOB or any ideas on fixing it?

The problem is the latest firmware. It has a lot of problems and has been pulled by WD because of all the issues it has. The stuttering that you are describing is one of the issues. Roll back your firmware to the previously released version (1.06.15_V for the Live, or 1.06.16_B for the Live Plus). There are many threads here explaining how to roll back your firmware.

Take a look at this link:

Firmware Rollback

1 Like

Thanks for the information.

It’s a bit better after the firmware rollback from 1.11.14 to 1.10.13 although still not watchable. It’s gone from being almost unnavigable and playing at 1 frame every few seconds to playing roughly a second smoothly, then stopping for a second and so on. I’m hoping it’s just because it’s rebuilding my media library so I’ll try again later.

A quick side note that because it’s a gen 3 wd tv live (WDBGXT0000NBK), the link is

Perhaps I was suposed to post this in the “WD TV Live Streaming” forum? It doesn’t actually say “Streaming” in the model name anywhere on the device or packaging. The first place I’ve seen it is on that firmware rollback page.

Yes, you posted in the wrong forum and FYI, the bottom sticker of the WDTV reads “Streaming”. Still, it’s WD’s fault using a confusing naming scheme. I also can’t reproduce your troubles on any firmware, maybe because I use ISOs exclusively. Have you turned of DVD menu support?

Turning the DVD menu off seems to stop DVD isos from playing at all. It just shows a black screen. This could be down to unskippable copyright warnings, trailers etc that tend to be at the start of DVDs, but I left a few ISOs on for a good 5 to 10 minutes each and none of them showed anything but black. If I try to “skip to desired time” the seek bar disappears almost instantly.

ISOs are still not playing smoothly even on the rolled back 1.10.13 firmware.

As a side note, IMHO the word “streaming” placed after a model name does not necessarily constitute it being part of the model name. When the device is booted, the logo that appears on the TV says “WD TV Live” only. The front of the device also says this only. The box and quick start installation document both show “Streaming Media Player” in much smaller writing on the next line, below the model name, and the sticker on the bottom of the device says “WD TV Live Streaming Media Player”. In none of these is it clear that “Streaming” is part of the model name, and in all but one is the model name explicitly or implicitly given as “WD TV Live” only. “Streaming” is no more part of the model name than “Graphics” would be in an “NVIDIA xxxx Graphics Card” or “DVD” would be in a “Samsung XXXX DVD Player”. It could equally be a “WD TV” Live Streaming Media Player" (because live streaming exists) or a “WD TV Live Streaming Media” Player. The only place any distinction is given is between “Live” and “Streaming”. If there is a different forum for gen3 of this device, it should be distinguished by something other than the word “Streaming”, such as the model number or generation in parentheses to reduce threads in the wrong forum like this one.

Well, that’s WD marketing for you.

I’ve tried my DVD ISOs (with menu and main movie only) but there’s no stutter, no matter if DVD menu is on or off. I do however, always strip user prohibitions.