ISO DVD files playback issues with Firmware Version 2.06.10

Firmware Version 2.06.10 for WD TV Live Hub has broken ISO DVD playback, it works only for about 1 or 2 attempts and then it starts to give "Unable to play this file format" Once this bug manifests itself, it never plays ISO DVD files till you power cycle the WDTVLIVEHUB.

This problem started to appear with 2.05.08 which I did not use as it had the menu screen Gamma bug.

I had reported this bug when 2.05.08 was released please read it here   <<< ISO DVD PLAYBACK BUG >>>

I had to roll back to 2.04.13 where this problem does not exist.

It does not matter if the ISO DVD files are played from Internal Drive or Network attached Storage or USB, the problem is easily repeatable.

Anyone else having this issue? or is it only me…???

Please do not suggest the paper clip method of resetting the WDTVLIVEHUB… as I have already attempted that :wink:

WD please consider fixing this issue as it is surely a bug…


Vistawall:  No, you’re not alone.    I haven’t seen it in 2.06.10 YET, but I haven’t been playing much with this new version yet.

For me it’s NOT easily repeatable.   It seems completely random.   Sometimes in 2.05.08 I could watch for days without seeing the issue…  Then I’d see it back-to-back.

Not sure what the magic steps are to reproduce it.


There are no magic steps required, Just play the ISO DVD file, It will surely play for the “first” attempt, Stop the media, Attempt to resume the DVD playback and it will “resume” as expected, and all will be well for the length of the movie till you stop it in the middle or do FF or REW, or the second time you attempt to play the same DVD ISO media, it will start complaining and a big pop-up window will tell you that this type of media is unsupported please see the list of supported media files…

Once this happens, you are stuck. and subsequently none of the ISO DVD media files will ever play till you completely power cycle the WDTVLIVEHUB.

Looks that they added some new code to a new MENU in the Video Section known as “ENABLE DVD MENU”… Something tells me that it has something to do with it :dizzy_face:

Also as stated in the release notes, they must have attempted to fix the DVD ISO media playback’s RESUME function when Media Library is turned off and it does work when ISO DVD media is attempted  with 2.06.10 but only once or twice then the unable to play message triggers and playback of ISO DVD media stops.

Well they attempted to fix DVD resume playback and broke the whole thing in FW 2.06.10

Oh! Well, I am not using this FW or the previous FW 2.05.08 I am still stuck at FW 2.04.13 for a long time as they break something or the other.  :angry:


It happened to me tonight under 2.06.10…  

HOWEVER, your steps aren’t doing it for me…   I started and stopped a DVD three times (after the reboot from above) with no issues…  

But here’s something *I* am having a problem with.   RESUME is now TOTALLY broken for me.   If I try to restart any DVD, it always starts from the beginning, media library on or off doesn’t matter now.  :angry:

As I have backuped some of my DVDs from the collection in the living room for comfortable watching in the bedroom, I can only say 2.04.13 runs rock stable with ISOs.

The only problem is, that 2 of them only show black screens which is a menue issue (either of the backup program or the hub firmware). When I navigate to the preview window I can start the main movie that way. That’s a thing I can live with (it’s about 2% and good 2 handle).

Me too!!!

2.06.10 has broken my ISO playback capabilities.

I have about 3 dozen ISO on the hubs HDD which have played fine for months until I recently upgraded the firmware twice ending up at 2.06.10.  With 2.06.10 I can sometimes start a movie but it will often freeze and then gives me the unsupported file message.  From that point on, no ISOs will play, even ISOs that were playing fine 5 minutes before the error occured.

I am going to roll back.

I have several DVD ISO’s and have no problems. I have had occasional glitches in the past that were solved by UNPLUGGING THE DEVICE (is that what you mean by “power cycle”?) or by restoring factory settings. I wonder if it’s possible that there’s an issue with the way the ISO was created? Things to try: 1. Unplug the WDTVLIVE HUB power (turn it off first) 2. Restore factory default settings 3. create a new DVD ISO image using the program “imgburn” (rip with “dvd decrypter” or “passkey lite”; both free). The fastest way to create an ISO from a DVD is to have Passkey Lite running and create the ISO directly from Imgburn instead of copying to a folder first.


Looks that you are the lucky few who do not have issues with ISO DVDs, Can you please confirm that you are indeed running firmware version 2.06.10???

As far as the way DVD ISOs creation, Thanks for the tips, But I personally do not think it has anything to do with the type of program you use to create DVD ISOs as the same firmware 2.06.10 plays the same DVD ISO files first and possibly the second time for some others and starts giving unsupported file error.

How can you explain that it is the problem with the DVD ISO creation when all my collections work just fine magically when i downgrade to older version of Firmware??

I think WD did introuduce a bug by mistake when they attempted to fix the DVD RESUME function when media lib is OFF bug as described in the release notes.

Hope this helps

I have over 1400 DVD ISO files in network shares with no issues.

2.06.10 is another story. I can’t keep a network share up long enough to watch anything. I rolled back to 2.02.16 and incrementally up to 2.03.24 (pretty stable, so far) and am considering 2.04.13.

I also have issues since I updated to firmware 2.06.10 with ISO playback…

I can play 1 movie, stop, select another, stop, select another, stop, and then I get the same msg many of us get, that it’s not a supported playback format.  I didn’t have this problem with the earlier FW

I’m not rolling back yet, I hope WDC fix it ASAP so that it’s A OKAY again…

I guess I’m just adding my name to the chorus of people complaining about this issue. Since the updated to firmware 2.06.10 ISO playback doesn’t work as it previously did…

It has a BUG for sure.

And is easy to reproduce.

Just playback ANY DVD .iso file, for couple minutes, then stop and turn off the HUB.

Wait a minute or so, then turn on HUB.   Play  the very same .iso file, it will now prompt for “resume” or “restart”, if you choose “resume” there is a 99% probably it will reboot the player !

I see this a lot, so I’m forced to always choose “restart”, is the ONLY way so far (last FW) to overcome this bug.

Gradius wrote:

It has a BUG for sure.


And is easy to reproduce.


Just playback ANY DVD .iso file, for couple minutes, then stop and turn off the HUB.


Wait a minute or so, then turn on HUB.   Play  the very same .iso file, it will now prompt for “resume” or “restart”, if you choose “resume” there is a 99% probably it will reboot the player !


I see this a lot, so I’m forced to always choose “restart”, is the ONLY way so far (last FW) to overcome this bug.

What you’re describing is something totally different; I haven’t noticed anyone reporting REBOOTS on resume…

And I fixed MY problem from above;  I should have posted an update…   MY problem of RESUME not working was because my NAS permissions were screwed up in a hidden way that took me a while to discover.

When I was still using 2.06.10 my hub would go into an endless reboot cycle. I am now using 2.05.08 and I have the reboot issue occasionally. Often, I get a message that the file type is not supported. The unit usually just hangs. Sometimes after the title has started (7 seconds to 3 or 4 minutes) and sometimes it just won’t start playing.

The most stable (not actually stable - just the least buggy) firmware for me has been 2.04.13.

I don’t know what or how it happened, but ever since 2.06.10 I can’t get back to the almost error-free performance I was experiencing with 2.04.13 and 2.05.08. I’ve gone all the way back to the bug infested beginning and slowly updated to each firmware release. 2.05.08 may have a better Netflix interface, but 2.04.13 is more problem free. After multiple flashes, 2.06.10 still won’t keep any of my network shares long than about 10 minutes (usually about 7 minutes), it even loses complete computers. It’s just not an option for me, and does anyone really want the games?! I’d much rather be able to turn off all the “services” I’ll never use.

I’ve had the same issue with the last 2 or 3 FW updates. Although for me the problem seems a little more random.  Ultimately, I have to yank the power cord about every 2-3 days to get it to work again.

This is particularly annoying since EVERYTIME you cycle the power on this thing it has to “compile the library” AGAIN. It takes FOREVER when your library contains 3 TB of ISO files on a NAS device. Then the performance of the unit while trying to browse for a title during the compiling process is really sluggish.

The latest “feature” I’ve noticed is the unit seems to be randomly locked up from time to time with nothing but a blank screen. Add one more reason to yank the power cord…

Dear Western Digital - I love this product… but I HATE THIS PRODUCT.  Is that clear enough?

I think you need a new Q/A Manager.

I finally went back to 2.04.13, again, last Friday. I haven’t had to pull the power once. I have become really gun shy and did a software reset of the device (Setup - System - Reset Device) after I’d left the unit on overnight - usually a sure path to requiring a power cycle.

I am now experiencing an occasional audio blip (a second or less of silence when the title isn’t silent). It only happens with this unit, not the Live Plus or my computer. If I replay the section again, no problem. It occurs randomly, that is: anywhere from a few seconds to 4 about minutes between these blips.

Yep, this is getting rather frustrating with the last few firmware updates causing playback of ISO files for me (including latest 2.07.17)… Because I rip all my movies to ISO files this WD Hub might just become “another brick in the wall!”. However I will try rolling back to an older version of the firmware (2.04.13) as people have reported. All up I’ve been very happy with the user interface and features of the Hub but will seriously consider moving on to another manufacturer if things don’t improve soon. Any recommendations on other devices users have that works better with all file types? Your input appreciated

I do agree that since firmware update 2.04.13 that Blu-Ray ISO streaming is no longer clean. I have continued to get random audio drop outs from all later  firmware updates beyond 2.03.24. I do enjoy DDTrue HD support in 2.04.13 which is not available in 2.03.24. I have tried changing network settings and different routers to eliminate the random audio drop outs. Even with the latest release 2.08.13 I continue to have audio drop outs. They occur when streaming DVD or Blu-Ray ISO’s from either of my NAS’s (2x Drobo FS). Also seeing audio drops during local playback of MP3, DVD and BD ISo’s from the internal 1TB HD.  So I know it is not a network issue but a firmware problem. I suspect between DDTrueHD support and the additional services the hub is now over tasked.

It is nice to see that you no longer to have to select Yes when the BD menu fails to play. I guess that WD has decide not to allow BD-J menu support at that jump point and went with the massive service expansion instead. 

I would like to suggest that the services be disabled that are not desired and get back to a point where the WD HUB is usable with it’s prime function of streaming otherwise it will become an empty door stop when I remove the internal HD.

1 Like