ISCSI target setting gone after reboot

I have a EX4 running 1.05.30 firmware. I setup a iscsi target and able to connect it from my Win7. But after the Ex4 rebooted / power-cycled, the iscsi target setting is gone. How do I make the iscsi setting stay?

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

I had this happen to me once before but on from a power loss. Tech support helped me with the problem. What I ended up having to is recreate the ISCSI drive exactly as I did before (same name, same size) on the EX4 and it immediately reconnected to my PC. It did not take up any extra memory as if I had duplicate ISCSI drives. It’s almost like it just forgot they were there and it needed reminding. I thought they had fixed it in one of the recent firmware updates but maybe not. It only happened once but it was at least 2 or 3 firmware versions ago.

1 Like

I just went through the same experience. Giovanni in L2 support was very helpful - but I should acknowledge that this post from @csandhmech was a savior!

Here are my lessons:

  1. Powering down by pressing the power button on the device to cause a shutdown is not graceful, even though the display acknowledges that shutdown is in progress, takes a minute before disks spin down. Shutdown from admin console is required. {I don’t particularly agree, but that’s the word…}

  2. The Settings|Utilities|System Configuration|Save Config File and the counterpart Import File - are useless. This config file does not restore shares, nor does it restore iSCSI targets. This is a fundamental flaw in the product causing a point of failure that renders all other wonderful h/w redundancies in the product useless.

If you expect that a save config and a subsequent restore should recreate the iscsi targets - then make some noise!

Unfortunately, if this feature is not implemented, I’ll have to look again for an alternative to the WD EX4 ;-(