iSCSI Target just disappeared, support cannot help me!

Hi,

So here is a warning and a plea for help… I hve my EX2 set up with a RAID-1 array using two 3TB drives. I had the entire volume dedicated to a 3GB iSCSI target that was mapped to my server here. All worked great for months.

Then I had an extended power outage. When power came back up, my server could not connect to the iSCSI target in the EX2. I took a look at the device and saw that the iSCSI target list was empty and the device was no longer serving the target! I used SSH to verify that my .img file is still there… The data still exists. But I cannot get at any of it as it is locked away in the image file!

I called into support, fully expecting to have a terrible time getting escelated and bounced around until I might find someone who could talk me through rebuilding the iSCSI target list on the device by editing some config files or whatever… Well, after 3 different calls consuming more than 2 hours, I was told by tier 2 that what I wanted to do was “impossible” and that my only hope was to copy the .IMG file down to a local hard disk and attempt to access it with 7-ZIP or some other utillity that can open ISO IMG files.

Well, that simply is not true. I mean, set aside that I don’t have 3TB free here so I have to go buy a new hard drive to actually do this - or canabalize one of the two drives in the RAID array to manage this… But even if I do that, I am very sure that no app is going to easily open this iSCSI IMG file as it is NOT a standard disk image. I’m fairly sure that my only hope is to get the image off the drives, completely wipe them, use the EX2 to build a new iSCSI target volume with exactly the same parameters as the first one, and then hopefully move the IMG back and overwrite the one that gets created by my intermediate step.

I don’t even know if that will work. Support happily told me that I should have made a backup of my data and that RAID-1 is not really a backup solution. Yea, I know that. And shame on me for using iSCSI which seems to be the root of my nightmare. Had I just used the drive as an SMB share server, none of this would have happened.

So, does anyone know how I might access the data within this image? I mean, i can boot into Linux if that might help me to mount it - I’m not completely familiar with NAS iSCSI implementations and im also not sure what LInux distro the EX2 is based on. I believe that is something I need to know so that I know what kind of IMG this might be?

I dug on google and found one other guy who had this exact problem but his solution was to just blow everything out and go again. I really want to get the data out of this image if I can.

Thanks!

H

you didn’t said too much about what WD support told you  to do.

Have you tried a hard reset: - unplug network and power cable. Press and hold reset button on the back of EX2, then connect the power cable. Still hold the reset button for about 40 seconds ?

i do not know SSH, but i’m sure there has to be a way to atleast see all the files and maybe copy them

Hi,

Thanks for the reply.

Support told me to copy the IMG file down to a local drive (which I do not have a local drive with >3TB of free space on it, lol), and then they told me I could use 7-zip or some other “disk image viewer” to get the files out of the iSCSI disk image file.

So while I struggle with getting the file off of the NAS (I am going to take 2x 2TB drive here, erase them, and make a 4 TB RAID 0, I guess), I will then hit the roadblock of having this IMG file that I can in no way open.

I think there is a way to open it - there must be. But I believe I am limited by what format the EX2’s iSCSI application put the IMG file into. Even then I may have challenges around actually getting another NAS server set up to host it.

So that is why I am thinking about getting the file off of the NAS so that I can maybe use the NAS to create the same exact configuration (thereby rebuilding all of the iSCSI config data) and then I just replace the IMG file on the NAS with the one I copied down.

I have tried to do the software reset available on the web config’s settings page, but that did not help. I’ve also tried the long “scan” process (took hours) but it did not fix the fault, either.

try the method that I told you and see if that helps

Did you have any luck recovering your data? I am in the exact same scenario as you described, but unfortunately with an 11TB volume. I am currently copying the iSCSI image through SSH and hoping to be able to extract the contents.

Any details you could share would be helpful.

Just in case someone else comes across this thread with the same problem of iSCSI target disappearing I found a solution to get at the data.

I was able to extract the data by mounting the remote file system in Windows with win-sshfs and opening the iSCSI .IMG file in 7-zip.

In order to mount the file system I used win-sshfs, installed in compatibility(win7) mode on a Windows 10 machine. The official release of win-sshfs has a 32 bit integer overflow when interpreting large file sizes so a fix is needed.

I downloaded a fix from the Google code base and it works great now and recognizes large file sizes correctly. This fix is not integrated into the official release of win-sshfs.

If you want a copy of this you can download it here.

Win-SSHFS - https://code.google.com/archive/p/win-sshfs/downloads

Win-SSHFS Large File Size Fix - http://storage.googleapis.com/google-code-attachments/win-sshfs/issue-28/comment-4/bigfile_fix.zip

  1. Install Win-SSHFS (it installs the dokan lib, then needs to reboot and then finish the install)
  2. Overwrite the files in the Win-SSHFS install folder with the ones contained in the fix.

*TIPS
• Win-sshfs sits in your task tray when executed
• When running win-sshfs you need to save your connection settings any time you make a change to them before clicking mount(takes 10 seconds or so to mount).
• it will auto mount the home directory, so you need to use " …/… " as your mount directory in win-sshfs to be able to navigate to the iscsi_images directory

Hi, I know this is old but I have the same issue and need some assistance if someone could be so kind. I have two iscsi partitions that are missing. I don’t see them in the dash and I don’t know there names or IP. I understand with WinSCP you can connect and transfer off the IMG. How on earth do I do that?? Any asistance is greatly appreciated!

Hi,
Simply create a new target with the same name as the existing img file. Size you can specify any available on the disk. That’s all, good luck!