Is this HDD physically damaged?

There is a disk I want to recover data from. It is an internal SATA HDD WD Blue disk. I plug power supply and data cable. I can physically hear the disk working and it appears in the Disk Management, but has no label.

When I try to initialize it with MBR, it sometimes says “Incorrect function” and sometimes says “A device which does not exist was specified” and sometimes the “initialize disk” option is disabled. The error message is consistent in one session, but after rebooting the error message changes randomly.

Diskpart output:

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          223 GB  1024 KB        *
  Disk 1    Online             0 B      0 B
  Disk 2    Online         3726 GB      0 B
  Disk 3    Online         1863 GB      0 B

DISKPART> select disk 1

Disk 1 is now the selected disk.

DISKPART> detail disk

Disk ID: 00000000
Type   : SATA
Status : Online
Path   : 1
Target : 0
LUN ID : 0
Location Path : PCIROOT(0)#PCI(1700)#ATA(C01T00L00)
Current Read-only State : No
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

There are no volumes.

DISKPART> convert mbr

DiskPart has encountered an error: A device which does not exist was specified.
See the System Event Log for more information.

The error is sometimes “Incorrect function” (it is consistent with Disk Management).

Tried opening the disk with HxD, it opens the disk without any error, but the size is displayed as 0 bytes. Tried using WD Dashboard, but it cannot detect the device. Reinstalling driver did not help.

Is there any other info/logs I need to provide to get a better help?

Hi @user17452 ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: