Is this drive suppose to be connected DIRECTLY to the router to work?


#1

Hello great community,

We need your help and we know that here we have a lot of collective wisdom :wink:

Our drive works well connected directly to the router. But soon as we connect it to any switch in the network we cannot even ping it. And believe me that we tried four different switches.

Does somebody else have this problem? And better, does a network guru know what could cause such problem?

PS: We can ping any other device connected to the switch, except this drive.

Thank you


#2

In order for the WD software to detect your  NAS drive, it must be on the same network that allows broadcast traffic.  Otherwise, you must access the NAS directly via its IP.

I would suggest taking note of the MAC address and connect it directly to your router.  Then access the router and ensure the MAC address appears in the ARP table and take note of the IP address associated with the device.  (I believe by default, the NAS is configured for as a DHCP client so it should obtain and IP address as long as there is a DHCP server on  your network.

You mention you’re trying to ping it, but not sure if you’re pinging by IP or by hostname.


#3
  • the drive is on the same network as all the devices, of course.

  • there is only one network range present

  • all IPs are fixed, we do not use DHCP

  • we access devices only based on IPs, not names

  • we can ping the drive and access it when connected to the router, but not after connecting it to the switch

looks to me like the drive cannot handle too many hops in the network and that requires direct connection with the router

but… i do not find this normal… do you?

do you have a drive connected to a switch that works?

regards


#4

Definitely not normal.  I had my WD connected behind a couple switches before it got to my router.  If you’re on the same network, have you tried using the WD Discovery software? 


#5

Well, in some way, the mystery is resolved, but the problems still remains:
-    If we wire the entire network configuration, all works well
-    If we split in two the network using a wireless AP and a repeater/bridge, then the problem appears.
So it seems that the wireless link blocks in some way the traffic, but I cannot figure it out why and how to fix it for the moment.
Anyway, this became a network problem and I need to troubleshoot further.
But any advice will be more than welcome.