Is this a weird problem to have?


I’m discussing an issue which happened a while ago. My problem with this is that this means I cannot remember all the details, but I will try my best.

On the day of the issue, I tried to connect my drive (MyBook Thunderbolt Duo 8TB) to my Mac as normal. The Mac could not seem to connect to it, and then a dialog message came up. (Unfortunately, because it was a while ago, I cannot remember exactly what this message said.) I clicked on a button I thought would solve the issue (again, can’t remember what the message said), but then the drive somehow disappeared.

When I tried to connect it again, I could tell that it was not working as normal. Then, as now, the icon does not come up on my desktop, and Finder does not show anything. I am able to see it through Disk Utility on the Mac, and it says that the drive is ‘not mounted’. Physically, the drive itself is working fine when connected up - there is a light on at the front.

This is all I can offer at the moment. I know this is not much information to give, but if there are any further tools or methods I could use to collect more information, I would be happy to do this to help a better discussion of the issue.

I did contact WD Support themselves and, upon request, ran First Aid on Disk Utility. The result is the following statement:

“First Aid found corruption that needs to be repaired. To repair the startup volume, run First Aid from Recovery. Click Done to continue.”

WD then suggested I connect the Mac to the hard drive by ethernet. Sadly, the fact that the hard drive itself doesn’t appear to have an ethernet port anywhere seems to be indicative of the kind of help I would be getting from WD Support, so I decided to bring this here.

Here’s the inevitable point - there’s quite a lot of data in that hard drive I would stand to lose if I reformat it or something. I’ve learnt my lesson and have seriously upgraded my backup system since then, but didn’t want to give up on what could still be there and recoverable. To this end, I haven’t done anything else beyond the above until I get some better advice.

Hi nicholas1,

We have sent you a message. Please check your Community Message Inbox.