Is there any solution other than resetting the device?


#1

Hi,

I would like to know if there are known solutions for usual issues for the WD devices other than just resetting the device.

I am having issues with the WD software every now and then since I bought it and it is always something new. The last one I’m having is that sometimes I can’t log in into the cloud when not home because after typing user name and password the site will redirect back to the generic wd my cloud website and if I navigate to the log in window I need to log back in ending up in an endless loop.

Additionally I am not able to upload files since a couple of weeks, the progress bar won’t move forwards and the files won’t be uploaded.

I have had other issues in the past and the answer was always to do a device reset, which involved to at least loose the users I have created and do all the work from the start. But if I am going to have problems every two months I just don’t want to be doing that work again and again.

The hardware is fine, but the software is a p.i.t.a. and WD doesn’t seem to care about updating it to solve well known issues I see in this forum happen again and again.

Is there anywhere a list of solutions for known issues that do not involve resetting the device? That would be at least a start as far as WD doesn’t want to solve the many bugs and issues with the software.


#2

What WD “software” are you using where you are having problems?

Remote access to a My Cloud can be fickle at times. Sometimes one has to disable remote/cloud access in the My Cloud Dashboard > Settings, wait a few minutes, then reenable it.

For remote access it seems WD is pushing people to use the MyCloud.com web portal as they have put the WD Desktop program in end of life status and are no longer supporting it. WD Desktop may stop working with with the latest firmware update to certain My Cloud models.


#3

I’m having the issue on every possible way as soon as I try to reach my cloud outside the local net. I’ve tried with the iOS app, Safari and Chrome on Mac OS HighSierra and Mojave and also Chrome and Mozilla in Windows10.

It doesn’t seem to be an OS problem but more something related to a change in the local IP or something like that. I do sometimes need to restart my modem and it is possible that my WD device gets a different IP after restart so it seems unreachable from outside the local net. Restarting the WD device didn’t help.

Weird is that I can reach the device but can’t upload any files no matter if big or small size.


#4

Each time a router or combo router/modem reboots a new IP for remote access is created. Solution is to turn cloud access off and on momentarily, and if you have a My Cloud model that is easy to reboot, do that instead.

Yes, there is a “list” of known problem solutions for WD devices. Just go to support for your device and look in the Knowledge Database.