Is there any hope for the mycloud from disconnect?

I love my Mycloud but about every week it disconnects (indicator light turns white) from my system and I have to totally unplug and restart (and wait for it to populate). My ATT UVerse router is new and all cables are in good order.
If the thing stays online for more that a couple days (Blue indicator light) I am actually pleasantly surprised. I walk in the room each day to see if it hasnt gone on the fritz again.

With this much trouble, I would have been better off just buying a regular old hard drive and have been done with it. Now it seems I have a $200 paperweight.
The dashboard says the firmware is current.
In the past ive called their tech line but at this point its out of warranty so I suppose they wont be much help.
Maybe theres a special fix for this now?
Thanks

https://community.wd.com/search?context=category&context_id=105&q=Uverse&skip_context=false
1 Like

There is a known (and well discussed in the past) issue with AT&T Uverse routers and the My Cloud. WD Support even has a knowledgebase article on it…

https://support.wdc.com/knowledgebase/answer.aspx?ID=15086

1 Like

Thank you Bennor for that link. That looks very promising and I am going to be looking into getting one of those units. Do you know if the ‘white light’ disconnect issue on the MyCloud is indeed caused by the route?
Thank you

No way to know without more troubleshooting including putting a switch between the My Cloud and the router.

If you haven’t already you should assign a static IP address to the My Cloud by accessing the router’s administration screen and assigning an IP address to the My Cloud. Perform an internet search for your router model to learn more on how to access the router and assign an IP address to client devices like the My Cloud.

1 Like

Devices disappearing from the network are often down to IP addressing issues, so fixing the IP address as Bennor suggests is a good start.

The next time the device disappears off the network, check what the Ethernet port LEDs are indicating; the symptom associated with the known Uverse router problem is failure to auto-negotiate a connection rate, and no LEDs are lit. It may be that your router is establishing a connection, but then failing to maintain that connection for some reason; hence the suggestion to check the LEDs. The other obvious thing to do is to try different router ports, and different cables (make sure they’re at least Cat5e); they may be new, but that doesn’t mean they aren’t faulty. Rule out the basics first.

1 Like

http://www.frys.com/product/3333872?source=google&gclid=Cj0KEQjwhMjKBRDjxb31j-aesI4BEiQA7ivN-FPeijzZkiIKE8ZyRdqACAisMxdjR22j_Bbe0g2gsdgaAt_V8P8HAQ

Hi CPT, changing the ports and changing cables made no difference. I will check the LED status soon and report back.
I appreciate your time and concern to my question.
Two questions, first, is the switch in this link one that might work well for my situation?

Second question, can you share a link to instructions on how to assign an IP address to the Mycloud?

Thank you

It is better to use a Gigabit switch not a lower speed 10/100 fast Ethernet switch. For example here are two Gigabit switches at Fry’s. Both under $20. Often one can find a 5 port Gigabit switch on sale at Amazon for $10.

http://www.frys.com/product/8959663

http://www.frys.com/product/6466002

1 Like

Generally it is better to leave the My Cloud set to obtain the IP address automatically (the default setting) and access your router’s administration page and reserve an IP address for the My Cloud in the router. You will probably have to perform an Internet search for directions on how to do so for your router.

Otherwise if you want to set a static IP address through the My Cloud Dashboard, see the following WD Support document (or see the My Cloud User Manual or Dashboard embedded Help).

https://support.wdc.com/knowledgebase/answer.aspx?ID=14198

1 Like

I was hoping that the switch was going to solve this issue but it hasnt. I got the TP- Link 5-port desktop gigabit switch.
The white light of disconnectivity is back on. I was just using it with no problems about an hour earlier. It went 4 days this time before ‘white light’
The green LED is blinking steadily on the MyCloud just above where the eithernet cable plugs in.
I have not yet done anything in regard to the IP address. I am a little knowlegable about computers but not sure how IP adresses work.
Would it be good at this point to follow the link above to assign a static IP address?

Thank you,
I followed the instructions in “How to configure a My Cloud (single bay) device with a static IP” and after clicking “static”, My screen has a different box than the instructions. I get a box that says ‘Static Network Mode’ and asks for 2 ‘*’ items among others. the 2 *‘s are the required fields. One is ’ * IP Address’ and ’ * Netmask’. Can you help me to find where to get these?

[quote=“hotrodjohn71, post:13, topic:209536, full:true”]I get a box that says ‘Static Network Mode’ and asks for 2 ‘*’ items among others. the 2 *‘s are the required fields. One is ’ * IP Address’ and ’ * Netmask’. Can you help me to find where to get these?
[/quote]
Did you see the “How to obtain the Subnet Mask, Gateway IP address, and DNS address” link in Step 6 b of the “How to configure a My Cloud (single bay) device with a static IP”?

https://support.wdc.com/knowledgebase/answer.aspx?ID=14210

As for the IP address you want to use an IP address that is NOT used by any other device. And you typically want to use one that is not in the DHCP IP address pool the router/DHCP server hands out to DHCP clients on the local network.

It is better to not bother with using the My Cloud Dashboard to set a static IP, instead leave the Dashboard settings to default for that section. And instead access your router’s administration page and assign a static IP address through the router interface instead. Perform an internet search for your router model for more information/directions on how to reserve a static IP for a network device.

1 Like

I can appreciate your bearing with me on this issue. I am not a computer guru but know a little. Its like me being a locomotive machinist trying to explain how to do a job on a locomotive to someone who has never opened a tool box so I appreciate your time.
This stuff is just slightly too complicated for me. Hopefully someone can grab a cup of coffee and help me go through it step by step as I hate to quit and I hate when things dont work as they are intended like this My Cloud (or rather the ATT Uverse router)
I did follow the instructions in the link “How to obtain the Subnet Mask, Gateway IP address, and DNS address” and I have those 3 addresses, IP4v subnet mask, IP4v default gateway, and IP4v DNS Server and they are written down.
I want to set the static address to the MyCloud through the routers admin page as you suggested, but I have an NVG589 Arris ATT Uverse router, and when I go to the router admin page via its IP address, I am at a loss as how to proceed - The options are not the same as the ones I have watched in tutorials on you-tube.
I did a google search on how to set a static IP address to a device with an ATT Uverse Arris router but was at a loss there as well.

To reserve a static IP address on the NVG589 you would follow these general steps:

  1. Use your web browser to access the NVG589’s administration screen (typically: http://192.168.1.254).
  2. Select Home Broadband from the top menu.
  3. Select IP Allocation from the second level menu under the top menu.
  4. Enter the Device Access Code (often found on the side or bottom of the router). Note: This code is DIFFERENT from the code used to access the WiFi signal.
  5. Select the Allocate button to the right of the IP address/Mac Address of the My Cloud.
  6. Then select a specific Private Fixed address from the list. Note: You can use the same IP Address that is currently assigned to the My Cloud, just select it from the IP Allocation Entry list.
  7. Select the Save button to save the changes.
  8. The Allocation field for the My Cloud row should change from DHCP Allocation to Fixed Allocation.

Note: The above steps taken from a Frontier NVG589 router.

1 Like

Thank you for your reply and the very good instructions.
I followed the instructions and assigned a fixed allocation to the MyCloud on the Uverse gateway admin page. I used the same IP address and it is showing as fixed.
I restarted the computer, went to the MyCloud dashboard and went to Network, but it is still showing under Network Mode as being DHCP instead of static.

I might have found an answer to my question, I looked on the IP Allocation page on the uverse gateway admin page where I changed the MyCloud IP to fixed and found this:
“The IP Allocated clients are still configured as DHCP clients at the client end, but will always be served the same IP address by the device DHCP server.”

Would this effectively be a Static IP Address for the Mycloud?
Thank you

Yes

Thank you all so so so so so so so so so so so so so so so so MUCh!!! :slight_smile:

It is DHCP, but the address is permanently reserved for the MyCloud by the DHCP server; it will always give the MyCloud this address.

It is a good idea to do this for all the devices that are permanently or regularly attached to your home network, as it saves a lot of problems of devices failing to keep up with IP address changes.

Only leave truly dynamic addresses for visiting devices.