Is there a proper way to force full library rebuild?

I have two WDTV Live SMP devices and they weren’t updating with the latest graphics for some TV Shows. I tried “Clear Library” and unplugging and plugging back in all to no avail. So I unplugged the devices, deleted the .wd_tv directories in each of the four folders I have mapped and then plugged the first one back in. It told me there were 0 video files. So I tried to manually rescan each share and it told me it could not because it was set to “read only” which wasn’t the case. I tried deleting all shares and readding each of the four but it would not rebuild the library. It would create the .wd_tv directory and create the wdtv.cas2 file in each of the 4 mapped directories but there was also a lock file in each and the device would not rebuild the library. So I unplugged that device and cleared the directories again and then tried the other device and the same thing happened. I eventually had to reset BOTH back to factory defaults and reset up everything (I run Mojo as well) before it would scan all the files and properly display them.

So is there a way to force these devices to update their display images for folders/movies? Obviously it has problems for some reason if you delete these files.


This has been reported as an issue, you can take a look  here