Is my new drive dead?


I’m building a system with two hard drives.  One is a SSD 240GB drive for my operating systems (Ubuntu and OS X Mountain Lion), the other drive is a Western Digital Caviar Black 2TB mechanical drive.

The SSD drive works fine and I was able to install my operating systems.  The WD drive seems to be dead.  It shows up in the OS X disk utility, but I am unable to partition it.  The disk utility says that the drive does not have enough space to partition.  This is strange, since the WD drive is brand new and has never been formatted.

The WD drive doesn’t show up at all in Ubuntu. 

Tonight I went into the BIOS.  The WD drive is listed there, but the BIOS says that the drive has 0.0GB of space.  I tried swapping out the SATA cable, still 0.0GB of space.  I tried plugging it into another SATA port, still no change.

Is my WD drive dead?  OS X and the BIOS see it, but I am unable to format or partition it. 

I bought the drive on Dec. 27 and I only got around to finishing my system build this past weekend to the point where I could boot it up and make sure that everything is working.  I think I might have missed the 30 day exchange period offered by the computer store.  Before I request an RMA is there anything else I could try to see if it will work?


Check the link below to review the steps on how to format the hard drive. If the problem continues, replace it.

AIUI, if a drive spins up and reports a capacity of 0, then that is symptomatic of an internal fault, possibly a damaged firmware module.

Here is a screenshot of the Disk Utility in OS X.  Note the message “This disk is too small to contain partitions”, and also notice the total capacity is listed as 0 bytes.

The motherboard’s BIOS also lists the drive’s capacity as 0GB.