Is my brand new WD Blue dying already?

Summary: Newly purchased WD Blue drive WD20EZRZ drive is behaving strangely and diagnostic programs hang on it

Question: Should I return it? Is there something I can do to make it behave as it should? Please read on, and sorry to make this long (I am trying to describe the experience).


Last night:
Unpacked drive
Placed in (newly bought) external enclosure, connected via USB.

Following these instructions to partition and format a WD drive on Windows 10:

Steps 1-8 are followed per instructions, no surprises
At step 9, drive does not appear. Error message from Virtual Disk Manager: The format did not complete successfully

Somehow at this point I tried again (this time instead of offering drive D: at step 6, F: was offered). This time I got a ‘The device is not ready’ message.

I noticed Device Manager could see the disk. Disk Management program did not.

At this point I took a break. Powered off the disk of course.


  • tried connecting enclosure / USB to alternative computer: Disk Management does not recognize drive though Device Manager sees it.

  • back to first computer. Tried using alternative enclosure which is known to be working. No difference. So it’s not the computer, not Windows I think, not the enclosure.

Installed WD Data Lifeguard Diagnostic for Windows (‘DLGDIAG’)
Launched DLGDIAG and did ‘quick test’ - it reported some errors and offered to fix. I chose to fix. It said disk was good.

Launch Disk Management. It sees the disk. Go through steps 1-8 again. Once again, got ‘The device is not ready’ message
On clicking OK to the message, hourglass goes on. Disk Management program is non responsive. Wait, wait.

I switch off power to the drive, Disk Management program becomes responsive.

I switch drive power on. It spins up. Enclosure light is on, then switches off/on about four times, mostly slowly. Then stays on… Device Manager lists drive. Disk Management does not.

I restart Disk Management. It hangs, ‘Connecting to Virtual Disk Service…’
I switch off power to the drive, Disk Management program becomes responsive and behaves normally.

I close Disk Management, power on the disk, launch DLGDIAG
DLGDIAG says detecting devices… then disappears – it’s visible in Task Manager but nowhere else!?!

Power off disk
Launch DLGDIAG. It quickly comes to its normal window listing the existing powered-on drive
Close and restart DLGDIAG (why does it ask me to accept license agreement every time?)
Power on disk: as before, same flash pattern as before, I think. DLGDIAG non responsive. Kill DLGDIAG.

Device Manager lists disk. Properties non responsive.
Power on / on the disk. Same flash pattern as before.
Device Manager shows properties
Device Manager seemed to refresh. Try Properties again: non responsive. Power off disk

Thanks for reading. Is this a bad disk (scary if so) or is there something I’m doing wrong?

Hi there!

Did you try to connect HDD via SATA cable directly to motherboard instead of external enclosure with USB? There may be some incompatibility between the disk and your other devices. Of course, if you know that your alternative enclosure is 100% workable I think the problem with HDD but anyway try to connect it directly. If it fails again so I assume that your HDD is defective.

Thanks BrainstorM. It’s not very convenient for me to connect directly to motherboard. I am now certain both of the enclosures I’ve tried are 100% good, and I’ve concluded the problem is with the HDD. A bit of a surprise but there we go…