Is it dead?

I’m assuming it’s dead, but maybe someone can offer a suggestion.

I have a My Book Studio (2 years old), that I formatted both for Mac and PC (approx 1/2 and 1/2).  Don’t think I ever really used it with PC - mostly Mac for storing kids’ videos.   Worked fine for a while, then intermittently had trouble “waking up” - power was on but Mac didn’t “see” it.  Unplugging power, unplugging firewire cable, then replugging, seemed to wake it up.  It was a bearable problem.  Went a long time (months) without using it at all.  Now, I can’t get it to wake up at all.  Tried downloading WD Drive Manager - I THINK it installed, but I’m not a Mac user and I don’t find OSx as communicative as Windows (ok, you can laugh now).  It still won’t wake.  Tried using the USB instead of firewire.  Tried plugging it into my Windows 7 computer (USB) - doesn’t show up in Disk Management.

The thing powers up.  The lights in front are on, but no one’s home.  I’m not hearing it spin up.

Is it dead?  What else can I try?  What other info would help diagnose it?


No ideas, huh?

If it is out of warranty and you still want to make use, better try to open the enclosure and check the power supply inside.

If you’re not that technical, but still capable of working in a desktop PC, (like installing a hard disk drive) you could attach SATA drive used inside the enclosure to a PC with long SATA cable. Then connect suitable spare power plug from PC directly to drive.

Try YouTube for how to > Open My Book Studio, Attach SATA drive to PC etc.

If your (newly bare) drive unable to spin up while directly connected to PC, you can either bin it or contact data recovery professional if you happened to have important data in it.

If you elect to bin it, you could replace My Book Studio with a new larger capacity drive. Make sure the electronics inside My Book is in proper working order.

Mabikay – SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. …