Is down? "Cannot establish remote access connection"

I tried to configure remote access (web, mobile) - last year it worked perfectly. Now I updated everything and it stopped. No matter what I did - resetting the web access, rebooting the drive - I always got: “Cannot establish remote access connection. Make sure you are connected to the Internet. (Error 31520)” 

Finally I tried to go to - no luck. The page seems to be down most of the time. I tried to access it from three independent devices using three independent internet providers. The best I got was to get a login form - this is as far as I got. Time out.

If the page is temporarily down, my humble request is, please LET USERS KNOW IT. One simple message would be enoguh - “The page is temporarily down. Sorry for the inconvenience. Check back later.” Is it asking too much?

And in My Live Book settings page: wouldn’t it be nice to let users know that, hypothetically, is down and stop the utterly misleading message “Make sure you are connected to the Internet. (Error 31520)”. I AM connected to the internet. And moreover, My Book Live, in its settings page “Network/Lan configuration/Internet Access” clearly says “GOOD”. 


This is a known issue. Take a look at this link for more information.