iPhone Auto Backup does not backup

#1

My iPhone needs to backup my photos every day, at minimum every other day. It is connected to wifi at least 12-18 hours out of every day. Currently the ‘Activity’ screen says ‘Auto backup’ with the refresh circle icon, and underneath it says 'Waiting…" but nothing happens. The last photo I have backed up is from 2 weeks ago, and even then the photos from that time are not all there.

Also, when it was backing up, it seemed to be backing up in no particular order?

#2

I have reinstalled the app on the iPhone. I found another post on the same topic, and it may be the solution. The problem may be that the phone has to be unlocked for the duration of the backup. I will report later if this is not my solution… Otherwise, thanks!

#3

Hello,

Please keep us posted on your issue, hopefully what you found helps fix it.

#4

It is not backing up because you never turn off the My Cloud app (being minimized does not count as “off”. The app only uploads when it turns on, checks for new photos, and then does its thing. All apps need to be turned off often, too.

#5

The phone is currently backed up. The problem is that when I go into my folder on the iPhone app, the default view is ‘All’. ‘All’ is not very convenient, because for me to see the most recent photos backed up, I have to scroll through the entirety of 2015 and 2016, which is quite a lot. But, when I get to the very bottom, I find the most recent picture. That is not really a problem.

The problem is that when I click from ‘All’ to select ‘Photos’, it only shows through January of 2016. The ‘Photos’ setting is convenient because it collects photos by month and year, but where are the photos from February 2016?? I found them in the ‘All’ selection? Does this have something to do with the cache size?

#6

Frankly, I found your reply confusing, and I had trouble understanding it all. I did understand that the ordering of photos is not what you want. I also got what you were caying about uploading in general, and it appears you manually upload versus using auto-backup feature. What I said above pertains to auto-backup, and I prefer to use manual backup/uploads.

I do not like that instead of seeing photos in my phone as most recently taken, I always need to begin at the very first picture taken and have to scroll down to get to the few new ones i need to upload.
If you agree with this, please see this link below and click on the heart symbol indicating you like the suggestion and maybe WD will fix the issue. Thanks

.

#7

Let me clarify myself. In the iPhone app, you can view the file system. You can view all files in a list, or you can view photos by date (year, month). To make this as simple as possible for you, let’s say I have 10 photos on the All view. In the Photo view, I only have 5. Why?

#8

OK, after your last post and my re-reading the entire thread again, I believe I have this figured out.

Apparently, auto-backup or uploads only occur from a fresh startup of the My Cloud app. It is not constantly scanning for new uploads (which is good). Instead, upon each start of the app, auto-backup looks for new Camera Roll items that need uploading and does it.

So, best practice with this app is that before commencing (or expecting) an upload, be sure app is completely off or turn it off, then turn it on (or back on), and things will work fine.

Another recently reported problem is that a person was getting error messages preventing complete uploads, all because of a lack of storage memory caused by a stuffed-full iPhone; meaning, too many apps were installed and running, too many downloads were saved in various apps and the iPhone had nowhere to go, memory-wise. Clean up your phone, firstly.

Also, follow the guidelines here:

Now, on to your particular issue: I agree, If you have 10 pictures in ALL you should see 10, not 5, in Photos sections of app. Maybe following the above tips will help to get all your pictures uploaded.

This will blow you away: If I have 10 photos in ALL, I see maybe 20 in Photos section! This is why: People can arrange their My Cloud differently. That is the device we are looking in when we use app to view photos, listen to music, etc. within the app.

As I said, anyone can arrange their My Cloud most anyway they can think of from the defaults setup: I surely do. I use the Public folder and the Shared media folders inside, but from there I arrange things in each Shared folder differently.

In my Shared Pictures, I have folders and not individual pictures from my iPhone and IPad. I have four folders, for the Camera Roll content, One for Phone and one for iPad In those, I have the Camera Roll divided into Photos and Videos. I also have a folder I named Collections for photos from my digital Camera.

So, this setup makes looking at my Photos quite different when viewed on the iPhone using the My Cloud app. To look exclusively at my iPhone photos I go into that folder and see all of those pictures when I view using the ALL tab. If I use Photos tab, I see all the folders in my Shared Pictures folder in My Cloud. I can view my folder called Collections with folders inside it. I also saw some individual “odd-ball” photos. They came from my Music stored on the My Cloud. Fortunately, I did not see the hundreds of album art in that folder, but I did see pictures I have stored in a few of the album folders; pictures I had edited of the album art.

OK, I think all this info will help you understand what is going on and why your uploads have not been complete.

#9

I found this thread because I’m having the same issue. Typically when I open the WD App on my iPHone, select activity, it starts backing up. Occasionally, it does not work and I see the “Waiting” status. Keeping the app open, (not closing the app) waiting a whole day, and still says “Waiting”.

Since I don’t keep photo’s on my iPhone, at best it’s waiting to backup about 15 photo’s… hardly a heavy lifting task for the app.

In the settings, I have it pointed directly to a folder where all iPhone photo’s should be sync’ed too on the My Cloud. After their up on WD, I remove them from my iPhone, and I clear cache.

When I’m tired of the waiting status, I go back to settings (in the iPhone app) and re-select the path for the app to sync up too. I return to status and immediately it starts to sync.

I don’t see the behavior as out of the box rather I see this as a defect. Something is wrong with the app where it looses sync and somehow probably needs to rebuild it’s index, thus the “waiting” status. By repointing the sync path in settings, I feel I’m forcing it to forgo the index and just do what I tell it to do.

Like I said, behavior is mixed bag… sometimes sync works, sometimes it doesn’t. I personally think the whole MyCloud solution is about half baked, and there are so many enhancements that could make it a better experience. It’s as if they took some good concepts about half way and said, “that’s good enough…”

1 Like
#10

Paul,
I had some new photos to upload today via MC app to my My Cloud, so I just did it and had no problem.

I have a folder in my MC Shared Pictures folder named My New Uploads, and when I turn on MC app I go to that folder (it needs to be empty each time before I upload new data.)

This is how I upload the photos/videos from iOS devices to the MC NAS:
I still keep the MC uploaded Camera Roll on my iPhone/Pad, so I keep auto-upload turned off so data is not uploaded again. While in that folder, I tap the three-dot menu in upper corner of screen and select Add Photo, and then the Camera Roll of iPhone appears, the content are in order of oldest first, so I have to scroll to bottom of contents to see the latest photos/videos and tap each to place a check mark in the ones I want to upload, and then tap the upload icon at bottom of screen. I can see the files being added.

That’s it, so now I get into the MC and move these newest additions into their final folders. I have two subfolders setup; one for me and one for my wife with four subfolders iin each for iPhone photos, iPhone videos, iPad photos, and iPad videos. Works great for me, try it.

#11

Hi Gents,
I have exactly same problem described in the first post - one month’s new picture and wait status under the auto backup process. I am sure it is nothing to do with folder issue. The new picture is 100% not sync to MYWDCLOUD. I have tried power off and on to make sure the WD app is close and open again but it does not trigger the auto backup to start.

In fact, this is not my first time to get into this problem. Last time I removed the WD App directly and reinstall again to set up the auto backup setting and backup the pictures and videos from the beginning. It is about 30G data and I don’t want to do it again and again.

Could someone please help me?
If I disable auto backup and enable again, will it back up everything from the beginning again? (Which is not I want)
If I remove the device ( WD MY CLOUD) and set up the device again, will it help?

Thanks in advance.

#12

Did you read and follow my post above about the auto-lock issue entitled “Backing up iPhone/iPad photos with My Cloud app? READ THIS”

My Cloud Backup for iOS not backing up all files
#13

Hi mike,
Yes I have read that before I make my post above. I am a little confused that -
Should I keep my iPhone unlocked and stay with WD app opened in front to trigger auto backup to leave “wait” status?

I thought your post is talking about something when the auto backup process is already running and then keep WD app alive to get the job well done.

I hope the WD app could work just like Google Photo. I can see the progress of Google photo immediately when I open the google photo app.

#14

What my post says and means is to set the iPhone Auto-Lock to Never (lock) in the iPhone settings. Then, do your uploading of photos and videos from iPhone. Both the iPhone and WD app will remain working during the whole process. The phone app will let you see when it is finished. Since we do not want to leave auto-lock on Never permanently, reset it to the time value you want it to be.

You need to set auto-lock to Never again anytime you have more than just a few photos to upload that can occur during the lower auto-lock setting you prefer to keep phone set at.

#15

Hi mike, thanks for the prompt response. The problem is I do not know how to “do my uploading”. I want the WD app to upload new pictures automatically for me. I don’t want to upload manually. Since the feature is “auto backup” why is that the status of the feature is always “waiting”?

#16

Well. it does not work the way you want it to. If you have new pictures to upload you must begin the process with the MC app completely off. Then open the app and the app will check for new pictures and upload them. If you keep the app on in the the minimized, background condition and you take some more pictures they will not be uploaded until after the app is closed again and restarted/opened again.

Leaving the app in “idle” in the background will not cause it to upload any new pictures. This only happens when the app is restarted again. So, leaving app in background only will use battery power faster. Turn app completely off once finished using it. You can use app for viewing pictures and other app viewing, but it cannot upload new camera roll content unless app is restarted.

#17

Like I mentioned before, I have powered off and on my iPhone to make sure all app including WD app to restart from scratch. In fact, I did that because it didn’t work at all after I simply closed the app by removing WD app from the list which is shown by double click on the home button.

#18

It works now! I don’t know why but somehow I have been logged out from the WD app. After I log in again with exactly same auto backup setting, the backup engine starts to work. All my new photos seems to be uploaded correctly.

Here comes another problem, why is that some pictures are lost when I view my photos by sheet “Photos” and “view by date”? If I view my photos at same sheet, i.e. “Photos”, but “view all”, the missing pictures show up!

(I don’t know the exactly English terms used in the app because I use Chinese language interface)

#19

In the app’s Settings tab there is a Help section. Refer to that for more info. Glad it is working now.

#20

Understood. I will search this forum first. Thanks.