IOS APP ver 4.18 cannot reach login page on several iphones

Hello, My Cloud IOS 5 (build 4.18) cannot open login page !
tried on several iphones with different builds, to no avail
all previous versions of App , functioned very well (4.17.1 and before)
here is the page I receive after clicking login on any Apple Iphone, to start app

1 Like

Hello jirages,
I have the same error, cannot login with Apple iPhone (wd my cloud app OS5), My Cloud Pro Series 4-Bay NAS, Current Version is 5.20.113, Last Update Tuesday, 2022 February 08, 13:29:31.

I found the solution. Delete OS5 app from iphone.
Reset network settings on iphone from general-reset-reset network settings
Iphone reboots, reboot once more.
Go to settings - Safari-
switch off block pop-ups
extensions-switch off all if you have any
switch off also : Hide IP address- prevent cross site checking-block all cookies-fraudulent websites.

open safari and go to
login on the browser
go to app store and download os5 my cloud app
Open the app and it now opens the login page,
login and keep app open
close safari
return to settings and recheck all that you unchecked to be untracked again
to remove the based trackers in phone for the app, reset again network settings
after phone reboot, reconnect to your wifi, and open app. It will open normally
If you try to connect after resetting networks without local wifi the first time, it will not open. Just the first time on same network as your my cloud drive or NAS

The app uses trackers from adobe, google - facebook etc.