iOS App - No access over 4g

I have the App on my iPad. When I am connected to wifi, there’s usually no problem accessing my data. However, when I am not on WiFi, usiing Testras 4G network, I cannot connect to my WD Mycloud.
Whats up with that?

Using on home wifi is different than using remotely over cell data or even a different wi-fi. See your user manual; you need to have turned on Cloud Access/Cloud Service in your Settings/General section,and be sure it says it is connected. You can set this up and test it from home. Just have wi-fi turned off on iPad at home and use your cell plan and it should work. Be sure to turn wi-fi back on when done testing.

Thanks Mike, but that doesnt seem to help unless I have something wrong. Every setting involving My Cloud App on my Ipad says it has access to mobile data. Yet, as soon as I turn off Wifi and/or go out of Wifi range, I keep getting a message
“Drive offline
WD MyCloud is notaccessible.”
As soon as I turn the Wifi back on - no problems.

Since I have no problems accessing my NAS through iPhone remotely, I don’t have other suggestions other than reboot or reset your NAS. So, contact WD Support:

@MLS Can you access your My Cloud when the iPad is connected to a Wi-Fi network that is outside of your own home? If YES, the issue would be isolated to your 4G providers network.

The Answer is Yes.
But, If this cant be solved its a world of hurt. Im with Telstra - biggest 4g network provider in teh country and the only effective carrier in my area. :frowning:
Ill be ringing EWD support shortly.

Well, thats an exercise in futility. WD phone message tells me support is only available for 30 days - purchased this product a year ago.
So, still no solution!

it was working smooth on my android phone when it was running on android version 6.0.1 however as I have updated to android version 7.1.1 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it?

with regards
ViaMichelin PutLocker Google Earth

I wish I had some solid, knowledgeable advice for you. However, the only success I have had when this happens, and it does happen more often that I’d like, is to cycle the old ‘mode onoff’ switch.
So, turn the drive off, check to connection to your router, maybe even reboot the router and let that fully restart, then restart the WD drive. Let it sit there for about five minutes, maybe ten. If the solid blue light is on, check to see if you can access the drive locally, then remotely. The tiem lag is require because I think it needs a bit to set up the relay on the WD servers, wherever they are.

If not, restart it again.
I’ve just had this happen to me again today. It took 3 or 4 attempts before I got it working again, but it did come good.